aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/layerscape/ls-rcw/patches
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2018-07-03 11:07:06 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-09-22 21:20:56 +0200
commit89c4ed57b768449d58bb0830e98c9b99ea466feb (patch)
tree24c1f53ee159f5dd6c2bf4f1a39d79cc89fb6b49 /package/firmware/layerscape/ls-rcw/patches
parent984cf8d89dc40b1a1ed994d2e550e783240599dd (diff)
downloadupstream-89c4ed57b768449d58bb0830e98c9b99ea466feb.tar.gz
upstream-89c4ed57b768449d58bb0830e98c9b99ea466feb.tar.bz2
upstream-89c4ed57b768449d58bb0830e98c9b99ea466feb.zip
layerscape: update ls-rcw to LSDK-18.06
The rcw source code had been migrated to codeaurora for LSDK-18.06 release and the future release. The source code had also involved ls1012ardb/ls1012afrdm/ ls1088ardb/ls2088ardb rcw, so we updated ls-rcw to LSDK-18.06, reworked the makefile and dropped ls-rcw-bin package in this patch. Also reworked ls-rcw patch to adapt to the latest source code. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/firmware/layerscape/ls-rcw/patches')
-rw-r--r--package/firmware/layerscape/ls-rcw/patches/0001-rcw-support-byte-swapping-without-tclsh-tool.patch (renamed from package/firmware/layerscape/ls-rcw/patches/0001-rcw-add-a-python-script-for-byte-swapping.patch)50
1 files changed, 33 insertions, 17 deletions
diff --git a/package/firmware/layerscape/ls-rcw/patches/0001-rcw-add-a-python-script-for-byte-swapping.patch b/package/firmware/layerscape/ls-rcw/patches/0001-rcw-support-byte-swapping-without-tclsh-tool.patch
index a2b7140654..08492dd479 100644
--- a/package/firmware/layerscape/ls-rcw/patches/0001-rcw-add-a-python-script-for-byte-swapping.patch
+++ b/package/firmware/layerscape/ls-rcw/patches/0001-rcw-support-byte-swapping-without-tclsh-tool.patch
@@ -1,31 +1,34 @@
-From ebded197f9c12168d61973043fd9ebd5d49528a8 Mon Sep 17 00:00:00 2001
+From c87a500c45f36ad248b1298d63e590d1d7e74f12 Mon Sep 17 00:00:00 2001
From: Yangbo Lu <yangbo.lu@nxp.com>
-Date: Mon, 25 Dec 2017 14:11:02 +0800
-Subject: [PATCH] rcw: add a python script for byte swapping
+Date: Tue, 3 Jul 2018 11:06:47 +0800
+Subject: [PATCH] rcw: support byte swapping without tclsh tool
Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
---
- Makefile | 2 ++
- byte_swap.py | 32 ++++++++++++++++++++++++++++++++
- 2 files changed, 34 insertions(+)
+ Makefile | 4 ----
+ byte_swap.py | 32 ++++++++++++++++++++++++++++++++
+ qspi_swap.sh | 2 +-
+ 3 files changed, 33 insertions(+), 5 deletions(-)
create mode 100755 byte_swap.py
diff --git a/Makefile b/Makefile
-index fb55c8b..27e3ba2 100644
+index 9f0587e..393bb2c 100644
--- a/Makefile
+++ b/Makefile
-@@ -11,6 +11,8 @@ all install clean:
+@@ -13,10 +13,6 @@ TCLSH := $(shell command -v tclsh 2> /dev/null)
+ VER = $(shell git describe --tags)
+
+ all install clean:
+-ifndef TCLSH
+- $(error "tclsh is not available. please install it.")
+- exit 1
+-endif
@for board in $(BOARDS); do \
$(MAKE) -C $$board $@ DESTDIR=$(DESTDIR)/$$board; \
done
-+ chmod 755 ./byte_swap.py; \
-+ ./byte_swap.py ls1046ardb/RR_FFSSPPPH_1133_5559/rcw_1800_qspiboot.bin 8
-
- release: $(foreach board,$(BOARDS),rcw-$(board)-$(VER).tar.gz)
-
diff --git a/byte_swap.py b/byte_swap.py
new file mode 100755
-index 0000000..7ee4129
+index 0000000..386310e
--- /dev/null
+++ b/byte_swap.py
@@ -0,0 +1,32 @@
@@ -51,7 +54,7 @@ index 0000000..7ee4129
+ tmp = file.read()
+file.close()
+
-+with open(file_name + '.swap','wb') as file:
++with open(file_name + '.swapped','wb') as file:
+ for i in range(0, len(tmp) - 1, byte):
+ if(tmp[i:i+4].encode('hex')) == "08610040":
+ #print("PBI CRC command")
@@ -60,7 +63,20 @@ index 0000000..7ee4129
+ file.write(tmp[i:i+byte][::-1])
+file.close()
+
-+print("Swapped file: " + file_name + '.swap')
++print("Swapped file: " + file_name + '.swapped')
+diff --git a/qspi_swap.sh b/qspi_swap.sh
+index 0b58e44..d23fd8b 100755
+--- a/qspi_swap.sh
++++ b/qspi_swap.sh
+@@ -9,7 +9,7 @@ do
+ if [ "$board_name" = "$current_dir" ]; then
+ if [ -e $filename ]; then
+ swapped_file="$filename.swapped"
+- tclsh ../tools/byte_swap.tcl $filename $swapped_file 8
++ ../byte_swap.py $filename 8
+ fi
+ fi
+ done < $1
--
-2.7.4
+1.7.1