aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/ipq-wifi/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@googlemail.com>2017-03-15 11:49:14 +0100
committerJohn Crispin <john@phrozen.org>2017-03-22 09:45:18 +0100
commitfa03d441e96eeec0781ccbe757a3641c9dcec785 (patch)
tree662f42a062ee99e0688a48dd4bb695df6a65e6d8 /package/firmware/ipq-wifi/Makefile
parentaa47f5623a83be15949a080e77959f0f7db16041 (diff)
downloadupstream-fa03d441e96eeec0781ccbe757a3641c9dcec785.tar.gz
upstream-fa03d441e96eeec0781ccbe757a3641c9dcec785.tar.bz2
upstream-fa03d441e96eeec0781ccbe757a3641c9dcec785.zip
firmware: add custom IPQ wifi board definitions
On the ath10k-devel ML Michael Kazior stated: "board-2 is a key-value store of actual board files. Some devices, notably qca61x4 hw3+ and qca4019 need distinct board files to be uploaded. Otherwise they fail in various ways." [0]. Later on Rajkumar Manoharan explained: "In QCA4019 platform, only radio specific calibration (pre-cal-data) is stored in flash. Board specific contents are read from board-2.bin. For each radio appropriate board data should be loaded. To fetch correct board data from board-2.bin bundle, pre-cal/radio specific caldata should be loaded first to get proper board id. |My understanding until now was that: | | * pre-cal data + board-2.bin info == actual calibration data Correct." [1]. The standard board-2.bin from the ath10k-firmware-qca4019 barely works on the RT-AC58U. Especially 5GHz clients fail to connect at all and if they do, they have very low throughput even right next to the router. Currently, the solution for this problem is to supply a custom board-2.bin for every device. To implement this feature, this method makes use of: Rafał Miłecki's "base-files: add support for overlaying rootfs content". This comes with a few limitations: 1. Since there can only be one board-2.bin at the right location, there can only one board overwrite installed at any time. (All packages CONFLICT with each other. It's also not possible to "builtin" multiple package.) 2. updating ath10k-firmware-qca4019 will also replace the board-2.bin. For this cases the user needs to manually reinstall the wifi-board package once the ath10k-firmware-qca4019 is updated. To create the individual board-2.bin: Use the ath10k-bdencoder utility from the qca-swiss-army-knife repository: <https://github.com/qca/qca-swiss-army-knife> The raw board.bin files have to be extracted from the vendor's source GPL.tar archieves. Signed-off-by: Alexis Green <agreen@cococorp.com> Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
Diffstat (limited to 'package/firmware/ipq-wifi/Makefile')
-rw-r--r--package/firmware/ipq-wifi/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/package/firmware/ipq-wifi/Makefile b/package/firmware/ipq-wifi/Makefile
new file mode 100644
index 0000000000..2f1b280bec
--- /dev/null
+++ b/package/firmware/ipq-wifi/Makefile
@@ -0,0 +1,53 @@
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/version.mk
+
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+endef
+
+define Build/Compile
+endef
+
+ALLWIFIBOARDS:=rt-ac58u fritz4040 nbg6617
+ALLWIFIPACKAGES:=$(foreach BOARD,$(ALLWIFIBOARDS),ipq-wifi-$(BOARD))
+
+define Package/ipq-wifi-default
+ SUBMENU:=ath10k IPQ4019 Boarddata
+ SECTION:=firmware
+ CATEGORY:=Firmware
+ DEPENDS:=@TARGET_ipq806x +ath10k-firmware-qca4019
+ TITLE:=Custom Board
+endef
+
+define generate-ipq-wifi-package
+ define Package/ipq-wifi-$(1)
+ $(call Package/ipq-wifi-default)
+ TITLE:=Board for $(3)
+ CONFLICTS:=$(PREV_BOARD)
+ endef
+
+ define Package/ipq-wifi-$(1)/description
+This device custom package board-2.bin overwrites the board-2.bin
+file which is supplied by the ath10k-firmware-qca4019 package.
+
+This is package is only necessary for the $(3).
+Don't install it for any other device!
+ endef
+
+ define Package/ipq-wifi-$(1)/install-overlay
+ $(INSTALL_DIR) $$(1)/lib/firmware/ath10k/QCA4019/hw1.0
+ $(INSTALL_DATA) ./$(2) $$(1)/lib/firmware/ath10k/QCA4019/hw1.0/board-2.bin
+ endef
+
+ PREV_BOARD+=ipq-wifi-$(1)
+endef
+
+$(eval $(call generate-ipq-wifi-package,rt-ac58u,board-rt-ac58u.bin,ASUS RT-AC58U/RT-ACRH13))
+$(eval $(call generate-ipq-wifi-package,fritz4040,board-fritz4040.bin,AVM FRITZBox 4040))
+$(eval $(call generate-ipq-wifi-package,nbg6617,board-nbg6617.bin,ZyXEL NBG6617))
+
+$(foreach PACKAGE,$(ALLWIFIPACKAGES),$(eval $(call BuildPackage,$(PACKAGE))))