aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/ipq-wifi/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2020-01-19 00:00:52 +0100
committerChristian Lamparter <chunkeey@gmail.com>2020-01-26 01:20:46 +0100
commita59f1ec30f3316c8afffbaae39234cb562973f26 (patch)
tree835f69a24d9f038d61a01df205917ad17d71e921 /package/firmware/ipq-wifi/Makefile
parent51f30359783938a1be7ffbd08e508c1b6c9c449f (diff)
downloadupstream-a59f1ec30f3316c8afffbaae39234cb562973f26.tar.gz
upstream-a59f1ec30f3316c8afffbaae39234cb562973f26.tar.bz2
upstream-a59f1ec30f3316c8afffbaae39234cb562973f26.zip
ipq-wifi: drop deprecated .bin support
This patch converts the Qxwlan E2600AC image away from the deprecated .bin file and to the new .qca4019 method. As a result, we no longer need to carry around the legacy support for handling .bin files. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/firmware/ipq-wifi/Makefile')
-rw-r--r--package/firmware/ipq-wifi/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/package/firmware/ipq-wifi/Makefile b/package/firmware/ipq-wifi/Makefile
index eada8baf6f..610dee18e0 100644
--- a/package/firmware/ipq-wifi/Makefile
+++ b/package/firmware/ipq-wifi/Makefile
@@ -48,10 +48,8 @@ define ipq-wifi-install-one-to
$(INSTALL_DATA) $(1) $(2)/lib/firmware/ath10k/$(3)/board-2.bin
endef
-# Note: .bin deprecated; supports existing boards
-
define ipq-wifi-install-one
- $(if $(filter $(suffix $(1)),.QCA4019 .qca4019 .bin),\
+ $(if $(filter $(suffix $(1)),.QCA4019 .qca4019),\
$(call ipq-wifi-install-one-to,$(1),$(2),QCA4019/hw1.0),\
$(if $(filter $(suffix $(1)),.QCA9888 .qca9888),\
$(call ipq-wifi-install-one-to,$(1),$(2),QCA9888/hw2.0),\