aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/ipq-wifi/Makefile
diff options
context:
space:
mode:
authorMagnus Frühling <skorpy@frankfurt.ccc.de>2018-06-11 23:10:43 +0200
committerJohn Crispin <john@phrozen.org>2018-06-18 18:21:20 +0200
commit4b280ad91a6b155ac71c417aaa7bb5f4e328712f (patch)
tree12c6527b15891ded0972e1a9c42e79e60025de78 /package/firmware/ipq-wifi/Makefile
parent71ae0792bad1b0eeb476513e15b326409f15ccb0 (diff)
downloadupstream-4b280ad91a6b155ac71c417aaa7bb5f4e328712f.tar.gz
upstream-4b280ad91a6b155ac71c417aaa7bb5f4e328712f.tar.bz2
upstream-4b280ad91a6b155ac71c417aaa7bb5f4e328712f.zip
ipq40xx: add support for ZyXEL WRE6606
Specifications: SOC: Qualcomm IPQ4018 (DAKOTA) ARM Quad-Core RAM: 128 MB Nanya NT5CC64M16GP-DI FLASH: 16 MiB Macronix MX25L12845EMI-12G ETH: Qualcomm QCA8072 WLAN1: Qualcomm Atheros QCA4018 2.4GHz 802.11b/g/n 2x2 WLAN2: Qualcomm Atheros QCA4018 5GHz 802.11n/ac W2 2x2 INPUT: WPS, Mode-toggle-switch LED: Power, WLAN 2.4GHz, WLAN 5GHz, LAN, WPS (LAN not controllable by software) (WLAN each green / red) SERIAL: Header next to eth-phy. VCC, TX, GND, RX (Square hole is VCC) The Serial setting is 115200-8-N-1. Tested and working: - Ethernet (Correct MAC-address) - 2.4 GHz WiFi (Correct MAC-address) - 5 GHz WiFi (Correct MAC-address) - Factory installation from tftp - OpenWRT sysupgrade - LEDs - WPS Button Not Working: - Mode-toggle-switch Install via TFTP: Connect to the devices serial. Hit Enter-Key in bootloader to stop autobooting. Command `tftpboot` will pull an initramfs image named `C0A86302.img` from a tftp server at `192.168.99.08/24`. After successfull transfer, boot the image with `bootm`. To persistently write the firmware, flash an openwrt sysupgrade image from inside the initramfs, for example transfer via `scp <sysupgrade> root@192.168.1.1:/tmp` and flash on the device with `sysupgrade -n /tmp/<sysupgrade>`. append-cmdline patch taken from chunkeeys work on the NBG6617. Signed-off-by: Magnus Frühling <skorpy@frankfurt.ccc.de> Co-authored-by: David Bauer <mail@david-bauer.net> Co-authored-by: Christian Lamparter <chunkeey@googlemail.com>
Diffstat (limited to 'package/firmware/ipq-wifi/Makefile')
-rw-r--r--package/firmware/ipq-wifi/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/firmware/ipq-wifi/Makefile b/package/firmware/ipq-wifi/Makefile
index d53ab298d4..1cfcc33de3 100644
--- a/package/firmware/ipq-wifi/Makefile
+++ b/package/firmware/ipq-wifi/Makefile
@@ -14,7 +14,7 @@ define Build/Compile
endef
#ALLWIFIBOARDS:=<devicename>
-ALLWIFIBOARDS:=
+ALLWIFIBOARDS:=zyxel_wre6606
ALLWIFIPACKAGES:=$(foreach BOARD,$(ALLWIFIBOARDS),ipq-wifi-$(BOARD))
define Package/ipq-wifi-default
@@ -48,6 +48,7 @@ Don't install it for any other device!
PREV_BOARD+=ipq-wifi-$(1)
endef
+$(eval $(call generate-ipq-wifi-package,zyxel_wre6606,board-zyxel_wre6606.bin,ZyXEL WRE6606))
#$(eval $(call generate-ipq-wifi-package,<devicename>,<filename>,<displayname>))
$(foreach PACKAGE,$(ALLWIFIPACKAGES),$(eval $(call BuildPackage,$(PACKAGE))))