aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/b43legacy-firmware
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-10-12 12:54:30 +0200
committerFelix Fietkau <nbd@nbd.name>2022-11-09 20:44:28 +0100
commita06e023b4e124dad2b2ddf3db87cb804b7043b26 (patch)
tree64a3dfcbc4ae2692c2670f37392e7955dc5d8c56 /package/firmware/b43legacy-firmware
parentf753316f4aa4764e80c4dbf6f2cc88922052da1e (diff)
downloadupstream-a06e023b4e124dad2b2ddf3db87cb804b7043b26.tar.gz
upstream-a06e023b4e124dad2b2ddf3db87cb804b7043b26.tar.bz2
upstream-a06e023b4e124dad2b2ddf3db87cb804b7043b26.zip
mac80211: remove old legacy legacy drivers
Get rid of drivers that are either limited to 802.11b/g or don't even support cfg80211/mac80211. Most of these are either limited to boards that we don't even support anymore because of firmware size, or were only used for custom hacks by a really small number of users in the past. Let's get rid of those to reduce the maintenance effort and the number of useless packages Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/firmware/b43legacy-firmware')
-rw-r--r--package/firmware/b43legacy-firmware/Makefile74
1 files changed, 0 insertions, 74 deletions
diff --git a/package/firmware/b43legacy-firmware/Makefile b/package/firmware/b43legacy-firmware/Makefile
deleted file mode 100644
index 43c530cc71..0000000000
--- a/package/firmware/b43legacy-firmware/Makefile
+++ /dev/null
@@ -1,74 +0,0 @@
-#
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=b43legacy-firmware
-PKG_VERSION:=3.130.20.0
-PKG_RELEASE:=1
-
-DL_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-
-PKG_SOURCE:=wl_apsta-$(PKG_VERSION).o
-PKG_SOURCE_URL:=@OPENWRT
-PKG_HASH:=7dba610b1d96dd14e901bcbce14cd6ecd1b1ac6f5c0035b0d6b6dc46a7c3ef90
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/b43legacy-firmware
- SECTION:=firmware
- CATEGORY:=Firmware
- URL:=$(PKG_SOURCE_URL)
- TITLE:=Broadcom bcm43xx b43legacy firmware
-endef
-
-define Package/b43legacy-firmware/config
- if PACKAGE_b43legacy-firmware
-
- config B43LEGACY_FW_SQUASH
- bool "Remove unnecessary firmware files"
- default y
- help
- This options allows you to remove unnecessary b43legacy firmware files
- from the final rootfs image. This can reduce the rootfs size by
- up to 50k.
-
- If unsure, say Y.
-
- config B43LEGACY_FW_SQUASH_COREREVS
- string "Core revisions to include"
- depends on B43LEGACY_FW_SQUASH
- default "1,2,3,4"
- help
- This is a comma separated list of core revision numbers.
-
- Example (keep files for rev4 only):
- 4
-
- Example (keep files for rev2 and rev4):
- 2,4
-
- endif
-endef
-
-define Build/Prepare
- mkdir -p $(PKG_BUILD_DIR)
-endef
-
-define Build/Compile
-
-endef
-
-define Package/b43legacy-firmware/install
- $(INSTALL_DIR) $(1)/lib/firmware
- b43-fwcutter --unsupported -w $(1)/lib/firmware/ $(DL_DIR)/$(PKG_SOURCE)
- ifneq ($(CONFIG_B43LEGACY_FW_SQUASH),)
- b43-fwsquash.py "G" "$(CONFIG_B43LEGACY_FW_SQUASH_COREREVS)" "$(1)/lib/firmware/b43legacy"
- endif
-endef
-
-$(eval $(call BuildPackage,b43legacy-firmware))