aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/ath10k-firmware
diff options
context:
space:
mode:
authorBen Greear <greearb@candelatech.com>2017-01-26 16:11:27 -0800
committerFelix Fietkau <nbd@nbd.name>2017-02-01 17:49:53 +0100
commit7cb27b462cefdb25d374f295c7721bdfa320a8c2 (patch)
treeb3e9efe9d104289414f4d94238853d28e9dfb8e9 /package/firmware/ath10k-firmware
parentf9c6cc277f75727cedcd982f21c7a2859922a0b5 (diff)
downloadupstream-7cb27b462cefdb25d374f295c7721bdfa320a8c2.tar.gz
upstream-7cb27b462cefdb25d374f295c7721bdfa320a8c2.tar.bz2
upstream-7cb27b462cefdb25d374f295c7721bdfa320a8c2.zip
ath10k-ct: Support ath10k CT firmware for 9887 chipsets.
And, update support for 9880 chipsets. The new firmware fixes a regression with EAPOL 4/4 packets added in a recent commit. It also fixes a case where the firmware would improperly try to use STBC when configured for 1x1 (as 9887 always is). Signed-off-by: Ben Greear <greearb@candelatech.com>
Diffstat (limited to 'package/firmware/ath10k-firmware')
-rw-r--r--package/firmware/ath10k-firmware/Makefile44
1 files changed, 41 insertions, 3 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index fa026e4352..08c65c053b 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ath10k-firmware
-PKG_SOURCE_DATE:=2017-01-11
+PKG_SOURCE_DATE:=2017-01-26
PKG_SOURCE_VERSION:=ab432c60437931a165f0aff1a6e3371f358b75dd
PKG_MIRROR_HASH:=e3188ecd4d7470d3cdde89fefa6258f9ec4f404b23558d1474e5014679b28101
PKG_RELEASE:=1
@@ -32,6 +32,11 @@ $(Package/ath10k-firmware-default)
TITLE:=ath10k firmware for QCA9887 devices
endef
+define Package/ath10k-firmware-qca9887-ct
+$(Package/ath10k-firmware-default)
+ TITLE:=ath10k-CT firmware for QCA9887 devices
+endef
+
QCA9887_REV:=3cce88e245f2d685e49411c4f80998f94baf67b8
QCA9887_FIRMWARE_FILE:=firmware-5.bin_10.2.4-1.0-00013
QCA9887_FIRMWARE_FILE_HASH:=5966408bd41f309edb595344b8dd088c0fed212debfd91e5f3e8a55ea119c16d
@@ -72,13 +77,20 @@ define Download/ct-firmware
URL_FILE:=$($(1)_FIRMWARE_FILE_CT)
endef
-QCA988X_FIRMWARE_FILE_CT:=firmware-2-ct-full-community.bin-19.rc1-lede
+QCA988X_FIRMWARE_FILE_CT:=firmware-2-ct-full-community.bin-19-rc3-lede
define Download/ath10k-firmware-qca988x-ct
$(call Download/ct-firmware,QCA988X,)
- HASH:=ad41b29a9eebf1066f993beb571f3bd13f14ea89336ef9d4f3b31ee57e7abe54
+ HASH:=4112d78161a2c20e7a9490ea8d04e9f919508bafb097d88761dcce026c26f93f
endef
$(eval $(call Download,ath10k-firmware-qca988x-ct))
+QCA9887_FIRMWARE_FILE_CT:=firmware-2-ct-full-community.bin-19-rc3-lede
+define Download/ath10k-firmware-qca9887-ct
+ $(call Download/ct-firmware,QCA9887,ath10k-9887)
+ HASH:=18b61875726d4384de46f75dec1d42fea31aa6d66dba4940cb9d375bc98732e4
+endef
+$(eval $(call Download,ath10k-firmware-qca9887-ct))
+
QCA99X0_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-9.bin-lede.001
define Download/ath10k-firmware-qca99x0-ct
$(call Download/ct-firmware,QCA99X0,ath10k-10-4)
@@ -107,6 +119,13 @@ $(Package/ath10k-firmware-default)
CATEGORY:=Firmware
endef
+define Package/ath10k-firmware-qca9887-ct
+$(Package/ath10k-firmware-default)
+ TITLE:=ath10k CT 10.1 firmware for QCA9887 devices
+ SECTION:=firmware
+ CATEGORY:=Firmware
+endef
+
define Package/ath10k-firmware-qca988x-ct/description
Alternative ath10k firmware for QCA988X from Candela Technologies.
Enables IBSS and other features. See:
@@ -116,6 +135,14 @@ is un-selected since the driver will try to load firmware-5.bin before
firmware-2.bin
endef
+define Package/ath10k-firmware-qca9887-ct/description
+Alternative ath10k firmware for QCA9887 from Candela Technologies.
+Enables IBSS and other features. See:
+http://www.candelatech.com/ath10k-10.1.php
+This firmware conflicts with the standard 9887 firmware, so select only
+one.
+endef
+
define Package/ath10k-firmware-qca99x0-ct/description
Alternative ath10k firmware for QCA99x0 from Candela Technologies.
Enables IBSS and other features. See:
@@ -224,6 +251,16 @@ define Package/ath10k-firmware-qca988x/install
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
endef
+define Package/ath10k-firmware-qca9887-ct/install
+ $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA9887/hw1.0
+ $(INSTALL_DATA) \
+ $(DL_DIR)/$(call CT_FIRMWARE_FILE,QCA9887) \
+ $(1)/lib/firmware/ath10k/QCA9887/hw1.0/firmware-2.bin
+ $(INSTALL_DATA) \
+ $(DL_DIR)/$(QCA9887_BOARD_FILE_DL) \
+ $(1)/lib/firmware/ath10k/QCA9887/hw1.0/board.bin
+endef
+
define Package/ath10k-firmware-qca988x-ct/install
$(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA988X/hw2.0
$(INSTALL_DATA) \
@@ -297,6 +334,7 @@ $(eval $(call BuildPackage,ath10k-firmware-qca99x0))
$(eval $(call BuildPackage,ath10k-firmware-qca6174))
$(eval $(call BuildPackage,ath10k-firmware-qca9984))
+$(eval $(call BuildPackage,ath10k-firmware-qca9887-ct))
$(eval $(call BuildPackage,ath10k-firmware-qca988x-ct))
$(eval $(call BuildPackage,ath10k-firmware-qca99x0-ct))
$(eval $(call BuildPackage,ath10k-firmware-qca9984-ct))