aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/ath10k-firmware
diff options
context:
space:
mode:
authorBen Greear <greearb@candelatech.com>2018-03-21 10:29:00 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2018-03-23 22:08:22 +0100
commit375be15429d89a3b6fbac52b62ea85a122db5ec1 (patch)
tree1e5aa6d70e8be11f1334fdf750fb62a1decc367d /package/firmware/ath10k-firmware
parent5f7d134454371233f8a1c06b65c400fb988bb5c9 (diff)
downloadupstream-375be15429d89a3b6fbac52b62ea85a122db5ec1.tar.gz
upstream-375be15429d89a3b6fbac52b62ea85a122db5ec1.tar.bz2
upstream-375be15429d89a3b6fbac52b62ea85a122db5ec1.zip
ath10k-ct: Update DEPENDS and PROVIDES
Update DEPENDS and PROVIDES so that ath10k-ct firmware and drivers can be used to replace stock firmware and drivers. The -htt firmware variant, which requires ath10k-ct driver now selects ath10k-ct driver when the firmware is selected. Signed-off-by: Ben Greear <greearb@candelatech.com>
Diffstat (limited to 'package/firmware/ath10k-firmware')
-rw-r--r--package/firmware/ath10k-firmware/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index 78d01d9035..aa925a4dc1 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -125,6 +125,7 @@ $(Package/ath10k-firmware-default)
TITLE:=ath10k CT 10.1 firmware for QCA988x devices
SECTION:=firmware
CATEGORY:=Firmware
+ PROVIDES:=ath10k-firmware-qca988x
endef
define Package/ath10k-firmware-qca9887-ct
@@ -132,6 +133,7 @@ $(Package/ath10k-firmware-default)
TITLE:=ath10k CT 10.1 firmware for QCA9887 devices
SECTION:=firmware
CATEGORY:=Firmware
+ PROVIDES:=ath10k-firmware-qca9887
endef
define Package/ath10k-firmware-qca988x-ct/description
@@ -198,6 +200,7 @@ $(Package/ath10k-firmware-default)
TITLE:=ath10k CT 10.4 firmware for QCA99x0 devices
SECTION:=firmware
CATEGORY:=Firmware
+ PROVIDES:=ath10k-firmware-qca99x0
endef
define Package/ath10k-firmware-qca9984-ct
@@ -205,6 +208,7 @@ $(Package/ath10k-firmware-default)
TITLE:=ath10k CT 10.4 firmware for QCA9984 devices
SECTION:=firmware
CATEGORY:=Firmware
+ PROVIDES:=ath10k-firmware-qca9984
endef
define Package/ath10k-firmware-qca4019-ct-htt
@@ -212,12 +216,15 @@ $(Package/ath10k-firmware-default)
TITLE:=ath10k CT 10.4 htt-mgt for QCA4018/9
SECTION:=firmware
CATEGORY:=Firmware
+ PROVIDES:=ath10k-firmware-qca4019
+ DEPENDS:=+kmod-ath10k-ct
endef
define Package/ath10k-firmware-qca4019-ct
$(Package/ath10k-firmware-default)
TITLE:=ath10k CT 10.4 firmware for QCA4018/9
SECTION:=firmware
CATEGORY:=Firmware
+ PROVIDES:=ath10k-firmware-qca4019
endef
define Package/ath10k-firmware-qca9888-ct
@@ -225,6 +232,7 @@ $(Package/ath10k-firmware-default)
TITLE:=ath10k CT 10.4 fw for QCA9886/8 devices
SECTION:=firmware
CATEGORY:=Firmware
+ PROVIDES:=ath10k-firmware-qca9888
endef
define Package/ath10k-firmware-qca9984