aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/ath10k-firmware
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-05-24 20:47:46 -0700
committerJohn Crispin <john@phrozen.org>2018-05-27 08:16:45 +0200
commit27eab4fa578d696ab55b6264a1b35fad6488b664 (patch)
tree77a003654c2e1690f6759c0f87591ec42208e320 /package/firmware/ath10k-firmware
parent5857088c5eb3a5a2409e3c57dbfa2487e08bbf4a (diff)
downloadupstream-27eab4fa578d696ab55b6264a1b35fad6488b664.tar.gz
upstream-27eab4fa578d696ab55b6264a1b35fad6488b664.tar.bz2
upstream-27eab4fa578d696ab55b6264a1b35fad6488b664.zip
ath10k-firmware: Fix QCA6174 support
Currently when installing the firmware, a bunch of files and directories that the ath10k driver does not look for are created. The package now installs firmware for both hw 2.1 and 3.0 devices. 2.1 is abandonware but may be useful to keep. 3.0 firmware was tested on a Killer 1535 to be relatively stable with 802.11w disabled. 802.11w causes multiple firmware crashes but that's true of other ath10k firmwares as well. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/firmware/ath10k-firmware')
-rw-r--r--package/firmware/ath10k-firmware/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index eaee0ebc51..2c024905bb 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -438,8 +438,22 @@ define Package/ath10k-firmware-qca988x/install
endef
define Package/ath10k-firmware-qca6174/install
- $(INSTALL_DIR) $(1)/lib/firmware/ath10k
- $(CP) $(PKG_BUILD_DIR)/QCA6174 $(1)/lib/firmware/ath10k/
+ $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA6174/hw2.1
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/QCA6174/hw2.1/board-2.bin \
+ $(1)/lib/firmware/ath10k/QCA6174/hw2.1/
+ $(INSTALL_DATA)
+ $(PKG_BUILD_DIR)/QCA6174/hw2.1/firmware-5.bin_SW_RM.1.1.1-00157-QCARMSWPZ-1 \
+ $(1)/lib/firmware/ath10k/QCA6174/hw2.1/firmware-5.bin
+ $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA6174/hw3.0
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/QCA6174/hw3.0/board-2.bin \
+ $(1)/lib/firmware/ath10k/QCA6174/hw3.0/
+ $(INSTALL_DATA)
+ $(PKG_BUILD_DIR)/QCA6174/hw3.0/4.4.1.c1/firmware-6.bin_RM.4.4.1.c1-00042-QCARMSWP-1 \
+ $(1)/lib/firmware/ath10k/QCA6174/hw3.0/firmware-6.bin
+ $(INSTALL_DATA)
+
endef
define Package/ath10k-firmware-qca99x0/install