aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/ath10k-firmware
diff options
context:
space:
mode:
authorBen Greear <greearb@candelatech.com>2016-10-17 14:23:01 -0700
committerFelix Fietkau <nbd@nbd.name>2016-10-19 11:13:15 +0200
commit1ffb7e47be92e32a08d866399af83d4136e28e06 (patch)
tree31cc24329a05064913da7a9b0c2dce6e63a6fb23 /package/firmware/ath10k-firmware
parent536420647a124f7330cfed323c36fa17c0824550 (diff)
downloadupstream-1ffb7e47be92e32a08d866399af83d4136e28e06.tar.gz
upstream-1ffb7e47be92e32a08d866399af83d4136e28e06.tar.bz2
upstream-1ffb7e47be92e32a08d866399af83d4136e28e06.zip
Latest ath10k CT 988X firmware (beta-18).
* Backport much of the 10.2 firmware features from upstream QCA driver. This includes ANI support, adaptive CCA, tx-hang workarounds, and lots of other things. Not all of this may be enabled at this point, and more code waits to be backported as time and motivation allows. * Fix some rate-control issues where ath10k in station mode (at least), would sometimes get stuck at low rates. This appeared to be a probe related state machine issue in the firmware, so I added some timeout logic to kick the state machine if it gets stuck. This signicantly improves throughput tests with many stations. * Support configuring WMI WD timeout using SET_SPECIAL API. * Properly configure the rx-mask on bootup to work around problem found by Mr. Kazior. This should remove the need to add the driver hack he posted. * Allow configuring pdev failed-retry threshold. This is how many consecutive tx failures the firmware will allow before resetting the wifi chip (not a full firmware crash). Signed-off-by: Ben Greear <greearb@candelatech.com>
Diffstat (limited to 'package/firmware/ath10k-firmware')
-rw-r--r--package/firmware/ath10k-firmware/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index 73309ad268..9ddfe92fc4 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -66,14 +66,14 @@ $(Package/ath10k-firmware-default)
CATEGORY:=Firmware
endef
-QCA988X_FIRMWARE_FILE_CT:=firmware-2-ct-full-community-16.1.bin-lede
+QCA988X_FIRMWARE_FILE_CT:=firmware-2-ct-full-community.bin-18.rc1-lede
QCA99X0_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-7.bin-lede.004
QCA9984_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-7.bin-lede.004
define Download/ath10k-firmware-qca988x-ct
URL:=https://www.candelatech.com/downloads/
FILE:=$(QCA988X_FIRMWARE_FILE_CT)
- MD5SUM:=d7e081e9782936ed544b78994c9133fb
+ MD5SUM:=89b436bad5d80c57bbf74e498095c9d2
endef
$(eval $(call Download,ath10k-firmware-qca988x-ct))