aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/amd64-microcode
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2018-10-31 18:48:38 +0100
committerJohn Crispin <john@phrozen.org>2018-11-26 12:05:45 +0100
commit975019b3a755ec3b91864b60b45e5ee104075096 (patch)
tree4fc22e1835cab455b99ce80ec5f662ac638bbd1f /package/firmware/amd64-microcode
parenta822283c7e56bb3b409712e0eb9af5a91aac247d (diff)
downloadupstream-975019b3a755ec3b91864b60b45e5ee104075096.tar.gz
upstream-975019b3a755ec3b91864b60b45e5ee104075096.tar.bz2
upstream-975019b3a755ec3b91864b60b45e5ee104075096.zip
amd64-microcode: create early load microcode image
Create initrd image with packed microcode. This'll allow to load it at early boot stage. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'package/firmware/amd64-microcode')
-rw-r--r--package/firmware/amd64-microcode/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/package/firmware/amd64-microcode/Makefile b/package/firmware/amd64-microcode/Makefile
index 4fd3d04610..adf3352af2 100644
--- a/package/firmware/amd64-microcode/Makefile
+++ b/package/firmware/amd64-microcode/Makefile
@@ -35,11 +35,17 @@ define Build/Prepare
endef
define Build/Compile
+ mkdir -p $(PKG_BUILD_DIR)/kernel/x86/microcode/
+ cat $(PKG_BUILD_DIR)/microcode_amd*.bin \
+ > $(PKG_BUILD_DIR)/kernel/x86/microcode/AuthenticAMD.bin
+ (cd $(PKG_BUILD_DIR); \
+ echo "kernel/x86/microcode/AuthenticAMD.bin" \
+ | cpio -o -H newc --reproducible > amd-ucode.cpio)
endef
define Package/amd64-microcode/install
- $(INSTALL_DIR) $(1)/lib/firmware/amd-ucode
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/*.bin $(1)/lib/firmware/amd-ucode
+ $(INSTALL_DIR) $(1)/boot
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/amd-ucode.cpio $(1)/boot/amd-ucode.img
endef
$(eval $(call BuildPackage,amd64-microcode))