aboutsummaryrefslogtreecommitdiffstats
path: root/package/firewall
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-03-02 19:20:29 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-03-02 19:20:29 +0000
commit13333a67423e02e4cb3e23ccf18ebdecf24a14dd (patch)
tree3a411abe76caf890c02a982dc2f50a5b4e561450 /package/firewall
parentd1f44a759855321c375c959f61f0bdfe1f9790ec (diff)
downloadupstream-13333a67423e02e4cb3e23ccf18ebdecf24a14dd.tar.gz
upstream-13333a67423e02e4cb3e23ccf18ebdecf24a14dd.tar.bz2
upstream-13333a67423e02e4cb3e23ccf18ebdecf24a14dd.zip
firewall: move include sourcing into a subshell, this makes the firewall init immune against exit in the include scripts
SVN-Revision: 25835
Diffstat (limited to 'package/firewall')
-rw-r--r--package/firewall/Makefile2
-rw-r--r--package/firewall/files/lib/core_init.sh6
2 files changed, 5 insertions, 3 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index 3d61e09889..a8a62c287d 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=2
-PKG_RELEASE:=22
+PKG_RELEASE:=23
include $(INCLUDE_DIR)/package.mk
diff --git a/package/firewall/files/lib/core_init.sh b/package/firewall/files/lib/core_init.sh
index c7e41e7ff7..42124b39bd 100644
--- a/package/firewall/files/lib/core_init.sh
+++ b/package/firewall/files/lib/core_init.sh
@@ -271,8 +271,10 @@ fw_load_notrack_zone() {
fw_load_include() {
local name="$1"
- local path; config_get path ${name} path
- [ -e $path ] && . $path
+ local path
+ config_get path ${name} path
+
+ [ -e $path ] && ( . $path )
}