aboutsummaryrefslogtreecommitdiffstats
path: root/package/firewall
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-02-23 18:50:47 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-02-23 18:50:47 +0000
commit716e67dbf7ee55ec010f3188b34864fbd0b42e0a (patch)
treeff626ca21a799be3b5fd436bf5b93ebee84f99a6 /package/firewall
parent1b20c8b960e4a213fc49658dee72166177f06a1b (diff)
downloadupstream-716e67dbf7ee55ec010f3188b34864fbd0b42e0a.tar.gz
upstream-716e67dbf7ee55ec010f3188b34864fbd0b42e0a.tar.bz2
upstream-716e67dbf7ee55ec010f3188b34864fbd0b42e0a.zip
[package] firewall: bail out if uci is used in firewall include files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30694 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firewall')
-rw-r--r--package/firewall/Makefile2
-rw-r--r--package/firewall/files/lib/core_init.sh8
2 files changed, 8 insertions, 2 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index 54cb8dc4a9..b03fca8a03 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=2
-PKG_RELEASE:=45
+PKG_RELEASE:=46
include $(INCLUDE_DIR)/package.mk
diff --git a/package/firewall/files/lib/core_init.sh b/package/firewall/files/lib/core_init.sh
index e93de1613f..035647998e 100644
--- a/package/firewall/files/lib/core_init.sh
+++ b/package/firewall/files/lib/core_init.sh
@@ -288,7 +288,13 @@ fw_load_include() {
local path
config_get path ${name} path
- [ -e $path ] && ( . $path )
+ [ -e $path ] && (
+ config() {
+ fw_log error "You cannot use UCI in firewall includes!" >&2
+ exit 1
+ }
+ . $path
+ )
}