aboutsummaryrefslogtreecommitdiffstats
path: root/package/firewall
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-08-14 00:33:29 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-08-14 00:33:29 +0000
commit3906d967645ce4fb6e4c99fd21170ea60691b7fe (patch)
tree68ab5235287f71b3c4431830466ddbbb97287f5c /package/firewall
parente0712a54a6c5559d2b49038dc99abd6390bc95c2 (diff)
downloadupstream-3906d967645ce4fb6e4c99fd21170ea60691b7fe.tar.gz
upstream-3906d967645ce4fb6e4c99fd21170ea60691b7fe.tar.bz2
upstream-3906d967645ce4fb6e4c99fd21170ea60691b7fe.zip
[package] firewall: further tune ICMPv6 default rules according to RFC4890 (#9893)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27979 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firewall')
-rw-r--r--package/firewall/Makefile2
-rw-r--r--package/firewall/files/firewall.config16
-rw-r--r--package/firewall/files/reflection.hotplug2
3 files changed, 18 insertions, 2 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index cdb8dc6224..b192ad330e 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=2
-PKG_RELEASE:=33
+PKG_RELEASE:=34
include $(INCLUDE_DIR)/package.mk
diff --git a/package/firewall/files/firewall.config b/package/firewall/files/firewall.config
index b47823fe2d..5a5dfd0186 100644
--- a/package/firewall/files/firewall.config
+++ b/package/firewall/files/firewall.config
@@ -44,6 +44,22 @@ config rule
option target ACCEPT
# Allow essential incoming IPv6 ICMP traffic
+config rule
+ option src wan
+ option proto icmp
+ list icmp_type echo-request
+ list icmp_type destination-unreachable
+ list icmp_type packet-too-big
+ list icmp_type time-exceeded
+ list icmp_type bad-header
+ list icmp_type unknown-header-type
+ list icmp_type router-solicitation
+ list icmp_type neighbour-solicitation
+ option limit 1000/sec
+ option family ipv6
+ option target ACCEPT
+
+# Allow essential forwarded IPv6 ICMP traffic
config rule
option src wan
option dest *
diff --git a/package/firewall/files/reflection.hotplug b/package/firewall/files/reflection.hotplug
index 15e350082a..1feb21075a 100644
--- a/package/firewall/files/reflection.hotplug
+++ b/package/firewall/files/reflection.hotplug
@@ -102,7 +102,7 @@ if [ "$ACTION" = "add" ] && [ "$INTERFACE" = "wan" ]; then
local p
for p in ${proto:-tcp udp}; do
case "$p" in
- tcp|udp)
+ tcp|udp|6|17)
iptables -t nat -A nat_reflection_in \
-s $lanip/$lanmk -d $exthost \
-p $p $extport \