aboutsummaryrefslogtreecommitdiffstats
path: root/package/firewall
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-02-07 18:35:48 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-02-07 18:35:48 +0000
commit1a0c80a2ddb77280316f16062cabd2f4143c17c4 (patch)
tree2803816b0ddf6cf21aa00209aff623e3285c83d7 /package/firewall
parent229d8a28779dbc2058410749ea821504f2b625f3 (diff)
downloadupstream-1a0c80a2ddb77280316f16062cabd2f4143c17c4.tar.gz
upstream-1a0c80a2ddb77280316f16062cabd2f4143c17c4.tar.bz2
upstream-1a0c80a2ddb77280316f16062cabd2f4143c17c4.zip
[package] firewall: don't filter IPv4 ICMP types (#10928)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30363 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firewall')
-rw-r--r--package/firewall/Makefile2
-rw-r--r--package/firewall/files/lib/fw.sh5
2 files changed, 2 insertions, 5 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index 746cca4882..978154b3f7 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=2
-PKG_RELEASE:=44
+PKG_RELEASE:=45
include $(INCLUDE_DIR)/package.mk
diff --git a/package/firewall/files/lib/fw.sh b/package/firewall/files/lib/fw.sh
index 0814ffc315..76e294f568 100644
--- a/package/firewall/files/lib/fw.sh
+++ b/package/firewall/files/lib/fw.sh
@@ -275,10 +275,7 @@ fw_check_icmptype4() {
export FW_ICMP4_TYPES=$(
iptables -p icmp -h 2>/dev/null | \
sed -n -e '/^Valid ICMP Types:/ {
- n; :r;
- /router-advertisement/d;
- /router-solicitation/d;
- s/[()]/ /g; s/[[:space:]]\+/\n/g; p; n; b r
+ n; :r; s/[()]/ /g; s/[[:space:]]\+/\n/g; p; n; b r
}' | sort -u
)