aboutsummaryrefslogtreecommitdiffstats
path: root/package/firewall
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-01-28 15:59:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-01-28 15:59:01 +0000
commit0c69bdccdafde89768727dcf367c3e9c28861fc5 (patch)
tree6332ff6145ab586ea26c06020f561f63682d062e /package/firewall
parent3cae2032bb3d4620857f01037231146a8ee0f292 (diff)
downloadupstream-0c69bdccdafde89768727dcf367c3e9c28861fc5.tar.gz
upstream-0c69bdccdafde89768727dcf367c3e9c28861fc5.tar.bz2
upstream-0c69bdccdafde89768727dcf367c3e9c28861fc5.zip
AA: firewall: backport r35348
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@35350 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firewall')
-rw-r--r--package/firewall/Makefile4
-rw-r--r--package/firewall/files/lib/core_interface.sh3
2 files changed, 5 insertions, 2 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index 4d7970a502..b2be06b30c 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2012 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=2
-PKG_RELEASE:=55
+PKG_RELEASE:=55.1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/firewall/files/lib/core_interface.sh b/package/firewall/files/lib/core_interface.sh
index 3d6718431f..7400e2d351 100644
--- a/package/firewall/files/lib/core_interface.sh
+++ b/package/firewall/files/lib/core_interface.sh
@@ -106,6 +106,9 @@ fw_configure_interface() {
fw $action $mode r PREROUTING ${chain}_notrack $ { -i "$ifname" $inet }
fw $action $mode n POSTROUTING ${chain}_nat $ { -o "$ifname" $onet }
+ # Flush conntrack table
+ echo f >/proc/net/nf_conntrack 2>/dev/null
+
lock -u /var/run/firewall-interface.lock
}