aboutsummaryrefslogtreecommitdiffstats
path: root/package/firewall/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-09-04 15:49:13 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-09-04 15:49:13 +0000
commitca5bf9e291d7ba8cbd6bd287cec22298809fba81 (patch)
tree7b12789be106bf1f7688b2f3926cfb00d23c13cf /package/firewall/Makefile
parent3e747a7f7534d1c7a5ac1b8e58b99a2585cac0c9 (diff)
downloadupstream-ca5bf9e291d7ba8cbd6bd287cec22298809fba81.tar.gz
upstream-ca5bf9e291d7ba8cbd6bd287cec22298809fba81.tar.bz2
upstream-ca5bf9e291d7ba8cbd6bd287cec22298809fba81.zip
firewall: - handle NAT reflection in firewall hotplug, solves synchronizing issues on boot - introduce masq_src and masq_dest options to limit zone masq to specific ip ranges, supports multiple subnets and negation
SVN-Revision: 22888
Diffstat (limited to 'package/firewall/Makefile')
-rw-r--r--package/firewall/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index 1c9c612f8a..40c82837fc 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=2
-PKG_RELEASE:=10
+PKG_RELEASE:=11
include $(INCLUDE_DIR)/package.mk
@@ -45,7 +45,8 @@ define Package/firewall/install
$(INSTALL_BIN) ./files/firewall.init $(1)/etc/init.d/firewall
$(INSTALL_DIR) $(1)/etc/hotplug.d/iface
$(INSTALL_DATA) ./files/firewall.hotplug $(1)/etc/hotplug.d/iface/20-firewall
- $(INSTALL_DATA) ./files/reflection.hotplug $(1)/etc/hotplug.d/iface/30-nat-reflection
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/firewall
+ $(INSTALL_DATA) ./files/reflection.hotplug $(1)/etc/hotplug.d/firewall/10-nat-reflection
$(INSTALL_DIR) $(1)/etc
$(INSTALL_DATA) ./files/firewall.user $(1)/etc
endef