aboutsummaryrefslogtreecommitdiffstats
path: root/package/ebtables
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-09 01:55:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-09 01:55:14 +0000
commit410831ce1112debcabbc120ecfc1431381b96b07 (patch)
tree3f7a60d66dcc7d52a22d67b45716585d391c2728 /package/ebtables
parent908e84df90b5d6f73f56f38f237653b5fea65501 (diff)
downloadupstream-410831ce1112debcabbc120ecfc1431381b96b07.tar.gz
upstream-410831ce1112debcabbc120ecfc1431381b96b07.tar.bz2
upstream-410831ce1112debcabbc120ecfc1431381b96b07.zip
update ebtables to 2.0.8-rc2 (#558)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3922 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ebtables')
-rw-r--r--package/ebtables/Makefile6
-rw-r--r--package/ebtables/patches/ebtables-2.0.6-gcc4.patch116
-rw-r--r--package/ebtables/patches/gcc3.4-ebtables_c.patch10
3 files changed, 3 insertions, 129 deletions
diff --git a/package/ebtables/Makefile b/package/ebtables/Makefile
index 04bb99d157..f6f01fac63 100644
--- a/package/ebtables/Makefile
+++ b/package/ebtables/Makefile
@@ -3,13 +3,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ebtables
-PKG_VERSION:=2.0.6
-PKG_RELEASE:=2
+PKG_VERSION:=2.0.8-rc2
+PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/ebtables-v$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/ebtables
-PKG_MD5SUM:=c4559af2366c764c6c42a3fdd40d60d3
+PKG_MD5SUM:=f07111fcc1966be669278433c35dcc28
PKG_CAT:=zcat
include $(TOPDIR)/package/rules.mk
diff --git a/package/ebtables/patches/ebtables-2.0.6-gcc4.patch b/package/ebtables/patches/ebtables-2.0.6-gcc4.patch
deleted file mode 100644
index cf64aed3aa..0000000000
--- a/package/ebtables/patches/ebtables-2.0.6-gcc4.patch
+++ /dev/null
@@ -1,116 +0,0 @@
-# --- T2-COPYRIGHT-NOTE-BEGIN ---
-# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
-#
-# T2 SDE: package/.../ebtables/gcc4.patch
-# Copyright (C) 2004 - 2005 The T2 SDE Project
-#
-# More information can be found in the files COPYING and README.
-#
-# This patch file is dual-licensed. It is available under the license the
-# patched project is licensed under, as long as it is an OpenSource license
-# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
-# of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or (at your option) any later
-# version.
-# --- T2-COPYRIGHT-NOTE-END ---
-diff -Nur ebtables-v2.0.6.orig/extensions/ebt_ip.c ebtables-v2.0.6/extensions/ebt_ip.c
---- ebtables-v2.0.6.orig/extensions/ebt_ip.c 2003-11-02 20:22:56.000000000 +0200
-+++ ebtables-v2.0.6/extensions/ebt_ip.c 2005-11-01 18:48:56.000000000 +0200
-@@ -244,6 +244,7 @@
- struct ebt_ip_info *ipinfo = (struct ebt_ip_info *)(*match)->data;
- char *end;
- long int i;
-+ unsigned char j;
-
- switch (c) {
- case IP_SOURCE:
-@@ -313,7 +314,7 @@
- ipinfo->invflags |= EBT_IP_PROTO;
- if (optind > argc)
- print_error("Missing IP protocol argument");
-- (unsigned char) i = strtoul(argv[optind - 1], &end, 10);
-+ j = strtoul(argv[optind - 1], &end, 10);
- if (*end != '\0') {
- struct protoent *pe;
-
-@@ -324,7 +325,7 @@
- argv[optind - 1]);
- ipinfo->protocol = pe->p_proto;
- } else {
-- ipinfo->protocol = (unsigned char) i;
-+ ipinfo->protocol = j;
- }
- ipinfo->bitmask |= EBT_IP_PROTO;
- break;
-diff -Nur ebtables-v2.0.6.orig/extensions/ebt_limit.c ebtables-v2.0.6/extensions/ebt_limit.c
---- ebtables-v2.0.6.orig/extensions/ebt_limit.c 2003-11-02 20:22:56.000000000 +0200
-+++ ebtables-v2.0.6/extensions/ebt_limit.c 2005-11-01 18:48:56.000000000 +0200
-@@ -203,15 +203,15 @@
-
- static struct ebt_u_match limit_match =
- {
-- .name EBT_LIMIT_MATCH,
-- .size sizeof(struct ebt_limit_info),
-- .help print_help,
-- .init init,
-- .parse parse,
-- .final_check final_check,
-- .print print,
-- .compare compare,
-- .extra_ops opts,
-+ .name = EBT_LIMIT_MATCH,
-+ .size = sizeof(struct ebt_limit_info),
-+ .help = print_help,
-+ .init = init,
-+ .parse = parse,
-+ .final_check = final_check,
-+ .print = print,
-+ .compare = compare,
-+ .extra_ops = opts,
- };
-
- static void _init(void) __attribute((constructor));
-diff -Nur ebtables-v2.0.6.orig/extensions/ebt_vlan.c ebtables-v2.0.6/extensions/ebt_vlan.c
---- ebtables-v2.0.6.orig/extensions/ebt_vlan.c 2003-11-02 20:22:56.000000000 +0200
-+++ ebtables-v2.0.6/extensions/ebt_vlan.c 2005-11-01 18:48:56.000000000 +0200
-@@ -135,14 +135,16 @@
- (struct ebt_vlan_info *) (*match)->data;
- char *end;
- struct ebt_vlan_info local;
-+ unsigned short id, encap;
-+ unsigned char prio;
-
- switch (c) {
- case VLAN_ID:
- check_option(flags, OPT_VLAN_ID);
- CHECK_INV_FLAG(EBT_VLAN_ID);
- CHECK_IF_MISSING_VALUE;
-- (unsigned short) local.id =
-- strtoul(argv[optind - 1], &end, 10);
-+ id = strtoul(argv[optind - 1], &end, 10);
-+ local.id = (uint16_t) id;
- CHECK_RANGE(local.id > 4094 || *end != '\0');
- vlaninfo->id = local.id;
- SET_BITMASK(EBT_VLAN_ID);
-@@ -152,8 +154,8 @@
- check_option(flags, OPT_VLAN_PRIO);
- CHECK_INV_FLAG(EBT_VLAN_PRIO);
- CHECK_IF_MISSING_VALUE;
-- (unsigned char) local.prio =
-- strtoul(argv[optind - 1], &end, 10);
-+ prio = strtoul(argv[optind - 1], &end, 10);
-+ local.prio = (uint8_t) prio;
- CHECK_RANGE(local.prio >= 8 || *end != '\0');
- vlaninfo->prio = local.prio;
- SET_BITMASK(EBT_VLAN_PRIO);
-@@ -163,8 +165,8 @@
- check_option(flags, OPT_VLAN_ENCAP);
- CHECK_INV_FLAG(EBT_VLAN_ENCAP);
- CHECK_IF_MISSING_VALUE;
-- (unsigned short) local.encap =
-- strtoul(argv[optind - 1], &end, 16);
-+ encap = strtoul(argv[optind - 1], &end, 16);
-+ local.encap = (uint16_t) encap;
- if (*end != '\0') {
- ethent = getethertypebyname(argv[optind - 1]);
- if (ethent == NULL)
diff --git a/package/ebtables/patches/gcc3.4-ebtables_c.patch b/package/ebtables/patches/gcc3.4-ebtables_c.patch
deleted file mode 100644
index 1973ea57f7..0000000000
--- a/package/ebtables/patches/gcc3.4-ebtables_c.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- ebtables-v2.0.6/ebtables.c 2003-11-02 19:22:56.000000000 +0100
-+++ ebtables-patch/ebtables.c 2005-03-29 08:03:09.734707134 +0200
-@@ -1171,6 +1171,7 @@
- continue;
- return i;
- letscontinue:
-+ {};
- }
- return -1;
- }