aboutsummaryrefslogtreecommitdiffstats
path: root/package/ebtables
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-05-09 23:20:58 +0000
committerMike Baker <mbm@openwrt.org>2006-05-09 23:20:58 +0000
commit1bfe23c0e1cfcaf4d725cf585a7b8c9ccfb8aa96 (patch)
tree94281b48593153be1e47a7296691ab0683729db8 /package/ebtables
parent52c3b7c0f2754e31d9068cc2aa3e75c79353c651 (diff)
downloadupstream-1bfe23c0e1cfcaf4d725cf585a7b8c9ccfb8aa96.tar.gz
upstream-1bfe23c0e1cfcaf4d725cf585a7b8c9ccfb8aa96.tar.bz2
upstream-1bfe23c0e1cfcaf4d725cf585a7b8c9ccfb8aa96.zip
Convert to new template
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3745 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ebtables')
-rw-r--r--package/ebtables/Config.in9
-rw-r--r--package/ebtables/Makefile35
-rw-r--r--package/ebtables/ipkg/ebtables.control5
3 files changed, 18 insertions, 31 deletions
diff --git a/package/ebtables/Config.in b/package/ebtables/Config.in
deleted file mode 100644
index e8fb884f75..0000000000
--- a/package/ebtables/Config.in
+++ /dev/null
@@ -1,9 +0,0 @@
-config BR2_PACKAGE_EBTABLES
- prompt "ebtables.......................... Ethernet bridge firewall administration utility"
- tristate
- default m if CONFIG_DEVEL
- help
- Ethernet Bridge Firewalling (ebtables)
-
- http://ebtables.sourceforge.net/
-
diff --git a/package/ebtables/Makefile b/package/ebtables/Makefile
index 9abd93a93a..04adbf6e82 100644
--- a/package/ebtables/Makefile
+++ b/package/ebtables/Makefile
@@ -5,28 +5,29 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ebtables
PKG_VERSION:=2.0.6
PKG_RELEASE:=1
-PKG_MD5SUM:=c4559af2366c764c6c42a3fdd40d60d3
-PKG_SOURCE_URL:=@SF/ebtables
-PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(BUILD_DIR)/ebtables-v$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/ebtables
+PKG_MD5SUM:=c4559af2366c764c6c42a3fdd40d60d3
PKG_CAT:=zcat
include $(TOPDIR)/package/rules.mk
-$(eval $(call PKG_template,EBTABLES,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
- CFLAGS="$(TARGET_CFLAGS) -Wall"
- touch $@
-
-$(IPKG_EBTABLES):
- mkdir -p $(IDIR_EBTABLES)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/ebtables $(IDIR_EBTABLES)/usr/sbin/
+define Package/ebtables
+SECTION:=base
+CATEGORY:=Network
+DEFAULT:=y
+TITLE:=Ethernet bridge firewall administration utility
+DESCRIPTION:=Ethernet Bridge Firewalling (ebtables)
+URL:=http://ebtables.sourceforge.net/
+endef
+
+define Package/ebtables/install
+ install -d -m0755 $(IDIR_DNSMASQ)/usr/sbin
+ install -m0755 $(PKG_BUILD_DIR)/ebtables $(IDIR_EBTABLES)/usr/sbin/ebtables
+ $(RSTRIP) $(IDIR_EBTABLES)
$(IPKG_BUILD) $(IDIR_EBTABLES) $(PACKAGE_DIR)
+ended
+$(eval $(call BuildPackage,ebtables))
diff --git a/package/ebtables/ipkg/ebtables.control b/package/ebtables/ipkg/ebtables.control
deleted file mode 100644
index 5dc6a14175..0000000000
--- a/package/ebtables/ipkg/ebtables.control
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: ebtables
-Priority: optional
-Section: net
-Description: Ethernet bridge firewalling software
-Depends: kmod-ebtables