aboutsummaryrefslogtreecommitdiffstats
path: root/package/e2fsprogs
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-07 08:34:51 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-07 08:34:51 +0000
commit2180fa92a1158fe8f660b3a69a8f9848309ce9b6 (patch)
tree0f9b6c1a366e3cdca242f1fbebe68337d21e3b7b /package/e2fsprogs
parentf2b24749083122a565ebf96a9143cb763d17345e (diff)
downloadupstream-2180fa92a1158fe8f660b3a69a8f9848309ce9b6.tar.gz
upstream-2180fa92a1158fe8f660b3a69a8f9848309ce9b6.tar.bz2
upstream-2180fa92a1158fe8f660b3a69a8f9848309ce9b6.zip
move package description to a separate definition, remove it when DESCRIPTION=TITLE
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8659 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/e2fsprogs')
-rw-r--r--package/e2fsprogs/Makefile37
1 files changed, 25 insertions, 12 deletions
diff --git a/package/e2fsprogs/Makefile b/package/e2fsprogs/Makefile
index 9192650c47..bb6e20aee3 100644
--- a/package/e2fsprogs/Makefile
+++ b/package/e2fsprogs/Makefile
@@ -18,7 +18,12 @@ PKG_MD5SUM:=06f7806782e357797fad1d34b7ced0c6
include $(INCLUDE_DIR)/package.mk
+define Package/e2fsprogs/Default
+ URL:=http://e2fsprogs.sourceforge.net/
+endef
+
define Package/e2fsprogs
+$(call Package/e2fsprogs/Default)
SECTION:=utils
CATEGORY:=Utilities
TITLE:=Ext2/3 filesystem utilities
@@ -29,36 +34,44 @@ define Package/e2fsprogs
filesystem utilities.
endef
+define Package/e2fsprogs/description
+ This package contains essential ext2 filesystem utilities which consists of
+ e2fsck, mke2fs, debugfs, dumpe2fs, tune2fs, and most of the other core ext2
+ filesystem utilities.
+endef
+
define Package/libuuid
+$(call Package/e2fsprogs/Default)
SECTION:=libs
CATEGORY:=Libraries
TITLE:=DCE compatible Universally Unique Identifier library
- DESCRIPTION:=\
- Library for generating DCE compatible Universally Unique Identifiers
- URL:=http://e2fsprogs.sourceforge.net/
+endef
+
+define Package/libuuid/description
+ Library for generating DCE compatible Universally Unique Identifiers.
endef
define Package/libblkid
+$(call Package/e2fsprogs/Default)
SECTION:=libs
CATEGORY:=Libraries
TITLE:=block device id library
- DESCRIPTION:=\
- The blkid library which allows system programs like fsck and mount to quickly\\\
- and easily find block devices by filesystem UUID and LABEL.
- URL:=http://e2fsprogs.sourceforge.net/
+endef
+
+define Package/libblkid/description
+ The blkid library which allows system programs like fsck and mount to
+ quickly and easily find block devices by filesystem UUID and LABEL.
endef
define Package/tune2fs
- $(call Package/e2fsprogs)
+$(call Package/e2fsprogs)
TITLE:=Ext2 Filesystem tune utility
- DESCRIPTION:=Ext2 Filesystem tune utility
DEPENDS:=e2fsprogs
endef
define Package/resize2fs
- $(call Package/e2fsprogs)
+$(call Package/e2fsprogs)
TITLE:=Ext2 Filesystem resize utility
- DESCRIPTION:=Ext2 Filesystem resize utility
DEPENDS:=e2fsprogs
endef
@@ -119,7 +132,7 @@ define Package/libuuid/install
endef
define Package/libblkid/install
- $(INSTALL_DIR) $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libblkid.so.* $(1)/usr/lib/
endef