aboutsummaryrefslogtreecommitdiffstats
path: root/package/e2fsprogs/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-06-13 17:20:36 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-06-13 17:20:36 +0000
commita65df2fe15c15e7b47dcc2ea97dbf707ef0f958d (patch)
tree22f28bc3ed7f67106264e25ef636e418ccdc316f /package/e2fsprogs/Makefile
parent8fb66187f4ae837249eaae4d53461cc2afe35f66 (diff)
downloadupstream-a65df2fe15c15e7b47dcc2ea97dbf707ef0f958d.tar.gz
upstream-a65df2fe15c15e7b47dcc2ea97dbf707ef0f958d.tar.bz2
upstream-a65df2fe15c15e7b47dcc2ea97dbf707ef0f958d.zip
Package libblkid from e2fsprogs
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7610 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/e2fsprogs/Makefile')
-rw-r--r--package/e2fsprogs/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/e2fsprogs/Makefile b/package/e2fsprogs/Makefile
index b2c1ba3063..1d56bacc8a 100644
--- a/package/e2fsprogs/Makefile
+++ b/package/e2fsprogs/Makefile
@@ -38,6 +38,16 @@ define Package/libuuid
URL:=http://e2fsprogs.sourceforge.net/
endef
+define Package/libblkid
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=block device id library
+ DESCRIPTION:=\
+ The blkid library which allows system programs like fsck and mount to quickly\\\
+ and easily find block devices by filesystem UUID and LABEL.
+ URL:=http://e2fsprogs.sourceforge.net/
+endef
+
define Package/tune2fs
$(call Package/e2fsprogs)
TITLE:=Ext2 Filesystem tune utility
@@ -94,6 +104,11 @@ define Package/libuuid/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libuuid.so.* $(1)/usr/lib/
endef
+define Package/libblkid/install
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libblkid.so.* $(1)/usr/lib/
+endef
+
define Package/tune2fs/install
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/tune2fs $(1)/usr/sbin/
@@ -106,5 +121,6 @@ endef
$(eval $(call BuildPackage,e2fsprogs))
$(eval $(call BuildPackage,libuuid))
+$(eval $(call BuildPackage,libblkid))
$(eval $(call BuildPackage,tune2fs))
$(eval $(call BuildPackage,resize2fs))