aboutsummaryrefslogtreecommitdiffstats
path: root/package/dropbear
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-15 23:46:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-15 23:46:30 +0000
commit947b9e0e9501105e71916c58dcbc67501f677bed (patch)
tree817b5cfa5d80cbda548b38a4a704e780c02ec68a /package/dropbear
parentce64e2d7f5aa350a96cc2a875f173e977a077ba2 (diff)
downloadupstream-947b9e0e9501105e71916c58dcbc67501f677bed.tar.gz
upstream-947b9e0e9501105e71916c58dcbc67501f677bed.tar.bz2
upstream-947b9e0e9501105e71916c58dcbc67501f677bed.zip
add dropbear host keys to conffiles
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7642 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/dropbear')
-rw-r--r--package/dropbear/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/dropbear/Makefile b/package/dropbear/Makefile
index 25a0cd0f55..60625947af 100644
--- a/package/dropbear/Makefile
+++ b/package/dropbear/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dropbear
PKG_VERSION:=0.49
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/ \
@@ -86,6 +86,9 @@ define Package/dropbear/install
$(INSTALL_DATA) ./files/dropbear.config $(1)/etc/config/dropbear
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/dropbear.init $(1)/etc/init.d/dropbear
+ $(INSTALL_DIR) $(1)/usr/lib/ipkg/info
+ echo /etc/dropbear/dropbear_rsa_host_key > $(1)/usr/lib/ipkg/info/dropbear.conffiles
+ echo /etc/dropbear/dropbear_dss_host_key >> $(1)/usr/lib/ipkg/info/dropbear.conffiles
endef
define Package/dropbearconvert/install