aboutsummaryrefslogtreecommitdiffstats
path: root/package/dropbear
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-03-25 11:03:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-03-25 11:03:26 +0000
commit93c1009e00ffc6c9266e03c73e176a078a2e351c (patch)
treee58a356b6cd028270242c74e9169a225daa07337 /package/dropbear
parent41d3213bd16b52dceae67888cc9767de8d25f869 (diff)
downloadupstream-93c1009e00ffc6c9266e03c73e176a078a2e351c.tar.gz
upstream-93c1009e00ffc6c9266e03c73e176a078a2e351c.tar.bz2
upstream-93c1009e00ffc6c9266e03c73e176a078a2e351c.zip
fix some dropbear client issues
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@453 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/dropbear')
-rw-r--r--package/dropbear/Makefile6
-rw-r--r--package/dropbear/patches/hostkey-prompt.patch12
-rw-r--r--package/dropbear/patches/scp-argument-fix.patch16
3 files changed, 32 insertions, 2 deletions
diff --git a/package/dropbear/Makefile b/package/dropbear/Makefile
index ef25b3ade5..72cc03005a 100644
--- a/package/dropbear/Makefile
+++ b/package/dropbear/Makefile
@@ -3,6 +3,7 @@
include $(TOPDIR)/rules.mk
DROPBEAR_VERSION:=0.45
+DROPBEAR_RELEASE:=2
DROPBEAR_MD5SUM:=2bcc46e4c239aec982bf36a723dd0b0e
DROPBEAR_SOURCE:=dropbear-$(DROPBEAR_VERSION).tar.bz2
@@ -11,7 +12,7 @@ DROPBEAR_DIR:=$(BUILD_DIR)/dropbear-$(DROPBEAR_VERSION)
DROPBEAR_CAT:=bzcat
DROPBEAR_BINARY:=dropbearmulti
DROPBEAR_TARGET_BINARY:=usr/sbin/dropbear
-DROPBEAR_IPK:=dropbear_$(DROPBEAR_VERSION)-1_$(ARCH).ipk
+DROPBEAR_IPK:=dropbear_$(DROPBEAR_VERSION)-$(DROPBEAR_RELEASE)_$(ARCH).ipk
DROPBEAR_IPK_DIR:=$(DROPBEAR_DIR)/ipkg
$(DL_DIR)/$(DROPBEAR_SOURCE):
@@ -53,7 +54,7 @@ $(DROPBEAR_DIR)/$(DROPBEAR_BINARY): $(DROPBEAR_DIR)/.configured
MULTI=1 SCPPROGRESS=1 -C $(DROPBEAR_DIR)
$(PACKAGE_DIR)/$(DROPBEAR_IPK): $(DROPBEAR_DIR)/$(DROPBEAR_BINARY)
- $(SCRIPT_DIR)/make-ipkg-dir.sh $(DROPBEAR_IPK_DIR) dropbear.control $(DROPBEAR_VERSION)-1 $(ARCH)
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $(DROPBEAR_IPK_DIR) dropbear.control $(DROPBEAR_VERSION)-$(DROPBEAR_RELEASE) $(ARCH)
mkdir -p $(DROPBEAR_IPK_DIR)/usr/bin
mkdir -p $(DROPBEAR_IPK_DIR)/usr/sbin
install -m 755 $(DROPBEAR_DIR)/$(DROPBEAR_BINARY) \
@@ -61,6 +62,7 @@ $(PACKAGE_DIR)/$(DROPBEAR_IPK): $(DROPBEAR_DIR)/$(DROPBEAR_BINARY)
$(STRIP) $(DROPBEAR_IPK_DIR)/usr/sbin/dropbear
ln -sf ../sbin/dropbear $(DROPBEAR_IPK_DIR)/usr/bin/scp
ln -sf ../sbin/dropbear $(DROPBEAR_IPK_DIR)/usr/bin/ssh
+ ln -sf ../sbin/dropbear $(DROPBEAR_IPK_DIR)/usr/bin/dbclient
ln -sf ../sbin/dropbear $(DROPBEAR_IPK_DIR)/usr/bin/dropbearkey
ln -sf ../sbin/dropbear $(DROPBEAR_IPK_DIR)/usr/bin/dropbearconvert
mkdir -p $(DROPBEAR_IPK_DIR)/etc/init.d
diff --git a/package/dropbear/patches/hostkey-prompt.patch b/package/dropbear/patches/hostkey-prompt.patch
new file mode 100644
index 0000000000..59639e7b97
--- /dev/null
+++ b/package/dropbear/patches/hostkey-prompt.patch
@@ -0,0 +1,12 @@
+diff -urN dropbear-0.45.old/cli-kex.c dropbear-0.45/cli-kex.c
+--- dropbear-0.45.old/cli-kex.c 2005-03-07 05:27:01.000000000 +0100
++++ dropbear-0.45/cli-kex.c 2005-03-25 11:13:57.000000000 +0100
+@@ -119,7 +119,7 @@
+ char response = 'z';
+
+ fp = sign_key_fingerprint(keyblob, keybloblen);
+- fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n)\n",
++ fprintf(stderr, "\nHost '%s' is not in the trusted hosts file.\n(fingerprint %s)\nDo you want to continue connecting? (y/n) ",
+ cli_opts.remotehost,
+ fp);
+
diff --git a/package/dropbear/patches/scp-argument-fix.patch b/package/dropbear/patches/scp-argument-fix.patch
new file mode 100644
index 0000000000..befba5d395
--- /dev/null
+++ b/package/dropbear/patches/scp-argument-fix.patch
@@ -0,0 +1,16 @@
+diff -urN dropbear-0.45.old/scp.c dropbear-0.45/scp.c
+--- dropbear-0.45.old/scp.c 2005-03-07 05:27:02.000000000 +0100
++++ dropbear-0.45/scp.c 2005-03-25 11:28:22.000000000 +0100
+@@ -249,9 +249,9 @@
+
+ args.list = NULL;
+ addargs(&args, "ssh"); /* overwritten with ssh_program */
+- addargs(&args, "-x");
+- addargs(&args, "-oForwardAgent no");
+- addargs(&args, "-oClearAllForwardings yes");
++// addargs(&args, "-x");
++// addargs(&args, "-oForwardAgent no");
++// addargs(&args, "-oClearAllForwardings yes");
+
+ fflag = tflag = 0;
+ while ((ch = getopt(argc, argv, "dfl:prtvBCc:i:P:q1246S:o:F:")) != -1)