aboutsummaryrefslogtreecommitdiffstats
path: root/package/dropbear
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-07-31 12:05:54 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-07-31 12:05:54 +0000
commit576e67e6f27c4fd3a4f6ee1b80e63ab355855b30 (patch)
tree1acb3c08dc65c2c01744bda212e408da4e8be8f3 /package/dropbear
parent751c44889a41ac4b63ea0f6f3baec87c418303b9 (diff)
downloadupstream-576e67e6f27c4fd3a4f6ee1b80e63ab355855b30.tar.gz
upstream-576e67e6f27c4fd3a4f6ee1b80e63ab355855b30.tar.bz2
upstream-576e67e6f27c4fd3a4f6ee1b80e63ab355855b30.zip
[package] dropbear:
- split port argument at the rightmost colon, allows binding to specific IPv6 addresses - don't use uci ipaddr var but resolve ifname and get addresses from it (#9853) git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27843 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/dropbear')
-rw-r--r--package/dropbear/Makefile4
-rwxr-xr-xpackage/dropbear/files/dropbear.init30
-rw-r--r--package/dropbear/patches/300-ipv6_addr_port_split.patch11
3 files changed, 38 insertions, 7 deletions
diff --git a/package/dropbear/Makefile b/package/dropbear/Makefile
index 3fba1347ef..34f064c37f 100644
--- a/package/dropbear/Makefile
+++ b/package/dropbear/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dropbear
PKG_VERSION:=0.53.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:= \
diff --git a/package/dropbear/files/dropbear.init b/package/dropbear/files/dropbear.init
index aa7e07dd6d..d06d2d5349 100755
--- a/package/dropbear/files/dropbear.init
+++ b/package/dropbear/files/dropbear.init
@@ -12,6 +12,27 @@ EXTRA_HELP=" killclients Kill ${NAME} processes except servers and yourself"
dropbear_start()
{
+ append_ports()
+ {
+ local ifname="$1"
+ local port="$2"
+
+ grep -qs "^ *$ifname:" /proc/net/dev || {
+ append args "-p $port"
+ return
+ }
+
+ for addr in $(
+ ifconfig "$ifname" | sed -ne '
+ /addr: *fe[89ab][0-9a-f]:/d
+ s/.* addr: *\([0-9a-f:\.]*\).*/\1/p
+ '
+ ); do
+ append args "-p $addr:$port"
+ done
+ }
+
+
local section="$1"
# check if section is enabled (default)
@@ -33,13 +54,12 @@ dropbear_start()
config_get_bool val "${section}" PasswordAuth 1
[ "${val}" -eq 0 ] && append args "-s"
# B) listen interface and port
+ local port
local interface
- local address
config_get interface "${section}" Interface
- config_get address "${interface}" ipaddr
- config_get val "${section}" Port
- val="${address:+${address}:}${val}"
- [ -n "${val}" ] && append args "-p ${val}"
+ config_get interface "${interface}" ifname "$interface"
+ config_get port "${section}" Port 22
+ append_ports "$interface" "$port"
# C) banner file
config_get val "${section}" BannerFile
[ -f "${val}" ] && append args "-b ${val}"
diff --git a/package/dropbear/patches/300-ipv6_addr_port_split.patch b/package/dropbear/patches/300-ipv6_addr_port_split.patch
new file mode 100644
index 0000000000..7da435ab15
--- /dev/null
+++ b/package/dropbear/patches/300-ipv6_addr_port_split.patch
@@ -0,0 +1,11 @@
+--- a/svr-runopts.c
++++ b/svr-runopts.c
+@@ -325,7 +325,7 @@ static void addportandaddress(char* spec
+ myspec = m_strdup(spec);
+
+ /* search for ':', that separates address and port */
+- svr_opts.ports[svr_opts.portcount] = strchr(myspec, ':');
++ svr_opts.ports[svr_opts.portcount] = strrchr(myspec, ':');
+
+ if (svr_opts.ports[svr_opts.portcount] == NULL) {
+ /* no ':' -> the whole string specifies just a port */