aboutsummaryrefslogtreecommitdiffstats
path: root/package/dropbear
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-09-07 10:00:34 +0000
committerMichael Büsch <mb@bu3sch.de>2010-09-07 10:00:34 +0000
commit48db317d21b3cd54c9162e9e9c9248643f3356f0 (patch)
tree5dadc86ab8f196d7ee7d84f83407b28befc254cf /package/dropbear
parentac52578132d05373a148bc7c98e16015f495fac2 (diff)
downloadupstream-48db317d21b3cd54c9162e9e9c9248643f3356f0.tar.gz
upstream-48db317d21b3cd54c9162e9e9c9248643f3356f0.tar.bz2
upstream-48db317d21b3cd54c9162e9e9c9248643f3356f0.zip
From: Joseph Roback <openwrt-devel@roback.cc>
26 Makefile patches for enabling parallel builds. Tested on Linux (8-core) and Darwin (12-core), individually and from clean build_root. The first set is from trunk, the second is from feeds/packages. Signed-off-by: Joe Roback <joe@roback.cc> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22965 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/dropbear')
-rw-r--r--package/dropbear/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/dropbear/Makefile b/package/dropbear/Makefile
index 77d6d9707b..6fad273660 100644
--- a/package/dropbear/Makefile
+++ b/package/dropbear/Makefile
@@ -17,6 +17,8 @@ PKG_SOURCE_URL:= \
http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
PKG_MD5SUM:=1c69ec674481d7745452f68f2ea5597e
+PKG_BUILD_PARALLEL:=1
+
include $(INCLUDE_DIR)/package.mk
define Package/dropbear/Default
@@ -70,12 +72,12 @@ define Build/Configure
endef
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
LD="$(TARGET_CC)" \
PROGRAMS="dropbear dbclient dropbearkey scp" \
MULTI=1 SCPPROGRESS=1
- $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
LD="$(TARGET_CC)" \
PROGRAMS="dropbearconvert"