aboutsummaryrefslogtreecommitdiffstats
path: root/package/dropbear
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-01-31 13:33:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-01-31 13:33:25 +0000
commit3d2bcfc931e4040c294b2c1e858c7d7d0f796aae (patch)
treee95d5fd6ffe0a63f93406a88105971fae454882f /package/dropbear
parent13dd24c6ffe00d5f9e284b213bbf36360f361c60 (diff)
downloadupstream-3d2bcfc931e4040c294b2c1e858c7d7d0f796aae.tar.gz
upstream-3d2bcfc931e4040c294b2c1e858c7d7d0f796aae.tar.bz2
upstream-3d2bcfc931e4040c294b2c1e858c7d7d0f796aae.zip
disable dropbear zlib support and split off dropbearconvert to save flash space
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3085 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/dropbear')
-rw-r--r--package/dropbear/Config.in6
-rw-r--r--package/dropbear/Makefile14
-rw-r--r--package/dropbear/ipkg/dropbearconvert.control5
-rw-r--r--package/dropbear/patches/150-dbconvert_standalone.patch14
4 files changed, 36 insertions, 3 deletions
diff --git a/package/dropbear/Config.in b/package/dropbear/Config.in
index 0c4b2f4527..5ed76a5506 100644
--- a/package/dropbear/Config.in
+++ b/package/dropbear/Config.in
@@ -2,9 +2,13 @@ config BR2_PACKAGE_DROPBEAR
prompt "dropbear.......................... Small SSH 2 client/server"
tristate
default y
- select BR2_PACKAGE_ZLIB
help
A small SSH 2 server/client designed for small memory environments.
http://matt.ucc.asn.au/dropbear/
+config BR2_PACKAGE_DBCONVERT
+ prompt "dropbearconvert................... Utility for converting SSH keys"
+ tristate
+ default m if CONFIG_DEVEL
+ depends BR2_PACKAGE_DROPBEAR
diff --git a/package/dropbear/Makefile b/package/dropbear/Makefile
index 36548877db..d43e70cfce 100644
--- a/package/dropbear/Makefile
+++ b/package/dropbear/Makefile
@@ -16,6 +16,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,DROPBEAR,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,DBCONVERT,dropbearconvert,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured:
$(SED) 's,^/\* #define PKG_MULTI.*,#define PKG_MULTI,g' $(PKG_BUILD_DIR)/options.h
@@ -58,15 +59,25 @@ $(PKG_BUILD_DIR)/.configured:
--disable-loginfunc \
--disable-pututline \
--disable-pututxline \
+ --disable-zlib \
);
touch $@
$(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR) \
LD=$(TARGET_CC) \
- PROGRAMS="dropbear dbclient dropbearkey dropbearconvert scp" \
+ PROGRAMS="dropbear dbclient dropbearkey scp" \
MULTI=1 SCPPROGRESS=1
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ LD=$(TARGET_CC) \
+ PROGRAMS="dropbearconvert"
touch $@
+
+$(IPKG_DBCONVERT):
+ mkdir -p $(IDIR_DBCONVERT)/usr/bin
+ install -m 755 $(PKG_BUILD_DIR)/dropbearconvert \
+ $(IDIR_DBCONVERT)/usr/bin/dropbearconvert
+ $(IPKG_BUILD) $(IDIR_DBCONVERT) $(PACKAGE_DIR)
$(IPKG_DROPBEAR):
mkdir -p $(IDIR_DROPBEAR)/usr/bin
@@ -78,7 +89,6 @@ $(IPKG_DROPBEAR):
ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/ssh
ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/dbclient
ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/dropbearkey
- ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/dropbearconvert
mkdir -p $(IDIR_DROPBEAR)/etc/init.d
install -m 755 ./files/S50dropbear $(IDIR_DROPBEAR)/etc/init.d/
$(IPKG_BUILD) $(IDIR_DROPBEAR) $(PACKAGE_DIR)
diff --git a/package/dropbear/ipkg/dropbearconvert.control b/package/dropbear/ipkg/dropbearconvert.control
new file mode 100644
index 0000000000..9dd5ecd1aa
--- /dev/null
+++ b/package/dropbear/ipkg/dropbearconvert.control
@@ -0,0 +1,5 @@
+Package: dropbearconvert
+Priority: optional
+Depends: zlib
+Section: net
+Description: Utility for converting SSH keys
diff --git a/package/dropbear/patches/150-dbconvert_standalone.patch b/package/dropbear/patches/150-dbconvert_standalone.patch
new file mode 100644
index 0000000000..50c035ae8c
--- /dev/null
+++ b/package/dropbear/patches/150-dbconvert_standalone.patch
@@ -0,0 +1,14 @@
+--- dropbear-0.47.old/options.h 2006-01-31 13:36:25.301562500 +0100
++++ dropbear-0.47.dev/options.h 2006-01-31 13:37:41.846346250 +0100
+@@ -5,6 +5,11 @@
+ #ifndef _OPTIONS_H_
+ #define _OPTIONS_H_
+
++#if !defined(DROPBEAR_CLIENT) && !defined(DROPBEAR_SERVER)
++#define DROPBEAR_SERVER
++#define DROPBEAR_CLIENT
++#endif
++
+ /******************************************************************
+ * Define compile-time options below - the "#ifndef DROPBEAR_XXX .... #endif"
+ * parts are to allow for commandline -DDROPBEAR_XXX options etc.