aboutsummaryrefslogtreecommitdiffstats
path: root/package/dnsmasq
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-06-18 18:27:23 +0000
committerNicolas Thill <nico@openwrt.org>2006-06-18 18:27:23 +0000
commit5448e327a35ac447794ff3d61900e8e9d16304ba (patch)
tree791b038f36256b47d748d0407239ab5adb6a9680 /package/dnsmasq
parent4ea556f52d116ef7ef2d5a9128839fb13539b438 (diff)
downloadupstream-5448e327a35ac447794ff3d61900e8e9d16304ba.tar.gz
upstream-5448e327a35ac447794ff3d61900e8e9d16304ba.tar.bz2
upstream-5448e327a35ac447794ff3d61900e8e9d16304ba.zip
add conffiles, use proper optimization flags when building.
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3997 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/dnsmasq')
-rw-r--r--package/dnsmasq/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index d3ce64736b..6efaf370a1 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -24,12 +24,24 @@ coupled DNS and DHCP service to a LAN.
URL:=http://www.thekelleys.org.uk/dnsmasq/
endef
+define Package/dnsmasq/conffiles
+/etc/dnsmasq.conf
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
+ BINDIR="/usr/sbin" MANDIR="/usr/man" \
+ all
+endef
+
define Package/dnsmasq/install
- install -m0755 -d $(1)/usr/sbin
- install -m0755 -d $(1)/etc/init.d/
- install -m0755 $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
+ install -m0755 -d $(1)/etc
install -m0644 ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
+ install -m0755 -d $(1)/etc/init.d
install -m0755 ./files/dnsmasq.init $(1)/etc/init.d/S50dnsmasq
+ install -m0755 -d $(1)/usr/sbin
+ install -m0755 $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,dnsmasq))