aboutsummaryrefslogtreecommitdiffstats
path: root/package/dnsmasq
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-04-09 14:51:15 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-04-09 14:51:15 +0000
commit2284341048e706fbf59527acc6ad9353acf66b1f (patch)
treea36e1e0144542b98715aad06ce99d4cbf0e93d74 /package/dnsmasq
parentbb2a858f834dd6470601b388b5b304ae87e1c019 (diff)
downloadupstream-2284341048e706fbf59527acc6ad9353acf66b1f.tar.gz
upstream-2284341048e706fbf59527acc6ad9353acf66b1f.tar.bz2
upstream-2284341048e706fbf59527acc6ad9353acf66b1f.zip
[package] dnsmasq: add more options for interface binding (#4900)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15172 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/dnsmasq')
-rw-r--r--package/dnsmasq/Makefile2
-rw-r--r--package/dnsmasq/files/dhcp.conf2
-rw-r--r--package/dnsmasq/files/dnsmasq.init2
3 files changed, 5 insertions, 1 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index 3599fa09ad..5fe1509601 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_VERSION:=2.47
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
diff --git a/package/dnsmasq/files/dhcp.conf b/package/dnsmasq/files/dhcp.conf
index 837be313ee..f34a0e9158 100644
--- a/package/dnsmasq/files/dhcp.conf
+++ b/package/dnsmasq/files/dhcp.conf
@@ -12,6 +12,8 @@ config dnsmasq
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
#list server '/mycompany.local/1.2.3.4'
+ #option nonwildcard 0
+ #option interfaces ''
config dhcp lan
option interface lan
diff --git a/package/dnsmasq/files/dnsmasq.init b/package/dnsmasq/files/dnsmasq.init
index 870414900f..0b2f630390 100644
--- a/package/dnsmasq/files/dnsmasq.init
+++ b/package/dnsmasq/files/dnsmasq.init
@@ -57,6 +57,7 @@ dnsmasq() {
append_bool "$cfg" boguspriv "-b"
append_bool "$cfg" expandhosts "-E"
append_bool "$cfg" enable_tftp "--enable-tftp"
+ append_bool "$cfg" nonwildcard "-z"
append_parm "$cfg" dnsforwardmax "-0"
append_parm "$cfg" port "-p"
@@ -71,6 +72,7 @@ dnsmasq() {
append_parm "$cfg" "resolvfile" "-r"
append_parm "$cfg" "tftp_root" "--tftp-root"
append_parm "$cfg" "dhcp_boot" "--dhcp-boot"
+ append_parm "$cfg" "interfaces" "-i"
config_get leasefile $cfg leasefile
[ -e "$leasefile" ] || touch "$leasefile"