aboutsummaryrefslogtreecommitdiffstats
path: root/package/dnsmasq
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-02 12:47:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-02 12:47:57 +0000
commitdc08d4eafccbc9fc2ccbe97f2e9022ed927d497a (patch)
tree850fcbd309b348f28b120778298ed7daa2ace5e9 /package/dnsmasq
parenta94738528451543fdd52b2760ae78205d5f5fb9c (diff)
downloadupstream-dc08d4eafccbc9fc2ccbe97f2e9022ed927d497a.tar.gz
upstream-dc08d4eafccbc9fc2ccbe97f2e9022ed927d497a.tar.bz2
upstream-dc08d4eafccbc9fc2ccbe97f2e9022ed927d497a.zip
dnsmasq: use -ffunction-sections, -fdata-sections and --gc-sections, saves 8k uncompressed
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25827 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/dnsmasq')
-rw-r--r--package/dnsmasq/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index 493797fa28..b71db58587 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -33,12 +33,15 @@ define Package/dnsmasq/conffiles
/etc/dnsmasq.conf
endef
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
BINDIR="/usr/sbin" MANDIR="/usr/man" \
AWK="awk" \
+ LDFLAGS="-Wl,--gc-sections" \
all
endef