aboutsummaryrefslogtreecommitdiffstats
path: root/package/dnsmasq
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2011-11-07 22:58:45 +0000
committerNicolas Thill <nico@openwrt.org>2011-11-07 22:58:45 +0000
commita13b6db678741695b029f0968e5253a85b70cf83 (patch)
tree6bbde0c690bf7ca691ec018b1397b0ca0c2b4d63 /package/dnsmasq
parent8b21997f14a67fdf4e9f4e0171d187feebccea2f (diff)
downloadupstream-a13b6db678741695b029f0968e5253a85b70cf83.tar.gz
upstream-a13b6db678741695b029f0968e5253a85b70cf83.tar.bz2
upstream-a13b6db678741695b029f0968e5253a85b70cf83.zip
package/dnsmasq: use new service wrapper
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28837 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/dnsmasq')
-rw-r--r--package/dnsmasq/Makefile2
-rw-r--r--package/dnsmasq/files/dnsmasq.init15
2 files changed, 10 insertions, 7 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index 540d47689e..1294a8b45f 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_VERSION:=2.58
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
diff --git a/package/dnsmasq/files/dnsmasq.init b/package/dnsmasq/files/dnsmasq.init
index 3d9060d81d..80ab250baa 100644
--- a/package/dnsmasq/files/dnsmasq.init
+++ b/package/dnsmasq/files/dnsmasq.init
@@ -2,6 +2,9 @@
# Copyright (C) 2007 OpenWrt.org
START=60
+
+SERVICE_USE_PID=1
+
DNS_SERVERS=""
DOMAIN=""
@@ -397,7 +400,7 @@ start() {
config_foreach dhcp_add dhcp
config_foreach dhcp_cname_add cname
- /usr/sbin/dnsmasq $args && {
+ service_start /usr/sbin/dnsmasq $args && {
rm -f /tmp/resolv.conf
[ -n "$DOMAIN" ] && echo "search $DOMAIN" >> /tmp/resolv.conf
DNS_SERVERS="$DNS_SERVERS 127.0.0.1"
@@ -408,10 +411,10 @@ start() {
}
stop() {
- [ -f /tmp/resolv.conf ] && {
- rm -f /tmp/resolv.conf
- ln -s /tmp/resolv.conf.auto /tmp/resolv.conf
+ service_stop /usr/sbin/dnsmasq && {
+ [ -f /tmp/resolv.conf ] && {
+ rm -f /tmp/resolv.conf
+ ln -s /tmp/resolv.conf.auto /tmp/resolv.conf
+ }
}
- service_kill dnsmasq /var/run/dnsmasq.pid
- return 0
}