aboutsummaryrefslogtreecommitdiffstats
path: root/package/dnsmasq
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-08-22 09:14:42 +0000
committerJohn Crispin <blogic@openwrt.org>2012-08-22 09:14:42 +0000
commit2f7f3ae094ff843214204c9dc6266d3dc6bbe5d3 (patch)
treeeb9e24f2da8592b120e35542da728fb759c93e88 /package/dnsmasq
parent38daca0070bcff0305a9b956f2c1af1d5227f3a1 (diff)
downloadupstream-2f7f3ae094ff843214204c9dc6266d3dc6bbe5d3.tar.gz
upstream-2f7f3ae094ff843214204c9dc6266d3dc6bbe5d3.tar.bz2
upstream-2f7f3ae094ff843214204c9dc6266d3dc6bbe5d3.zip
dnsmasq: Set prefix on-link bit in RAs
This is fix an issue with dnsmasq's RA that does not set the "on-link" bit, making all local IPv6 traffic go to the router then to the destination host, not directly to each other. patch is from dnsmasq git git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33216 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/dnsmasq')
-rw-r--r--package/dnsmasq/Makefile2
-rw-r--r--package/dnsmasq/patches/0001-Set-prefix-on-link-bit-in-RAs.patch42
2 files changed, 43 insertions, 1 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index f19e012635..7e06ec1720 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_VERSION:=2.62
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
diff --git a/package/dnsmasq/patches/0001-Set-prefix-on-link-bit-in-RAs.patch b/package/dnsmasq/patches/0001-Set-prefix-on-link-bit-in-RAs.patch
new file mode 100644
index 0000000000..8ead9afa59
--- /dev/null
+++ b/package/dnsmasq/patches/0001-Set-prefix-on-link-bit-in-RAs.patch
@@ -0,0 +1,42 @@
+From fd05f127909bbf4f6983a4de2dcb611947488dee Mon Sep 17 00:00:00 2001
+From: Simon Kelley <simon@thekelleys.org.uk>
+Date: Sun, 12 Aug 2012 17:48:50 +0100
+Subject: [PATCH] Set prefix on-link bit in RAs
+
+---
+ CHANGELOG | 3 +++
+ src/radv.c | 4 ++--
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/CHANGELOG b/CHANGELOG
+index 8828694..e1daeef 100644
+--- a/CHANGELOG
++++ b/CHANGELOG
+@@ -45,6 +45,9 @@ version 2.63
+ uk.org.thekelleys.dnsmasq. Thanks to Mathieu
+ Trudel-Lapierre for the patch.
+
++ Set the "prefix on-link" bit in Router
++ Advertisements. Thanks to Gui Iribarren for the patch.
++
+
+ version 2.62
+ Update German translation. Thanks to Conrad Kostecki.
+diff --git a/src/radv.c b/src/radv.c
+index a3e691a..d1f5268 100644
+--- a/src/radv.c
++++ b/src/radv.c
+@@ -412,8 +412,8 @@ static int add_prefixes(struct in6_addr *local, int prefix,
+ opt->type = ICMP6_OPT_PREFIX;
+ opt->len = 4;
+ opt->prefix_len = prefix;
+- /* autonomous only if we're not doing dhcp */
+- opt->flags = do_slaac ? 0x40 : 0x00;
++ /* autonomous only if we're not doing dhcp, always set "on-link" */
++ opt->flags = do_slaac ? 0xC0 : 0x80;
+ opt->valid_lifetime = htonl(time);
+ opt->preferred_lifetime = htonl(deprecate ? 0 : time);
+ opt->reserved = 0;
+--
+1.7.10.GIT
+