aboutsummaryrefslogtreecommitdiffstats
path: root/package/dnsmasq
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-04-23 13:40:50 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-04-23 13:40:50 +0000
commit20711d07232147887fed7dc3a393614b6ae143d7 (patch)
tree309cae6cd98c8a8405c2b2f167fb90682bfeb1e2 /package/dnsmasq
parentaad7fd42b9deb0b957e64c6852f4ef98aecf0208 (diff)
downloadupstream-20711d07232147887fed7dc3a393614b6ae143d7.tar.gz
upstream-20711d07232147887fed7dc3a393614b6ae143d7.tar.bz2
upstream-20711d07232147887fed7dc3a393614b6ae143d7.zip
[package] dnsmasq:
- when processing domain entries, append searchdomain to host entries if they are not fully qualified - create only one reverse record for address entries with multiple names git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21109 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/dnsmasq')
-rw-r--r--package/dnsmasq/Makefile2
-rw-r--r--package/dnsmasq/files/dnsmasq.init14
2 files changed, 12 insertions, 4 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index abf0962c37..77b8f82a67 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_VERSION:=2.52
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
diff --git a/package/dnsmasq/files/dnsmasq.init b/package/dnsmasq/files/dnsmasq.init
index 47c4c2d2e6..15f856d4e5 100644
--- a/package/dnsmasq/files/dnsmasq.init
+++ b/package/dnsmasq/files/dnsmasq.init
@@ -296,9 +296,17 @@ dhcp_domain_add() {
local raddr="${4:+$4.$3.$2.$1.in-addr.arpa}"
for name in $names; do
- append args "-A /$name/$ip"
- [ -n "$raddr" ] && \
- append args "--ptr-record=$raddr,$name"
+ local fqdn="$name"
+
+ [ "${fqdn%.*}" == "$fqdn" ] && \
+ fqdn="$fqdn${DOMAIN:+.$DOMAIN}"
+
+ append args "-A /$fqdn/$ip"
+
+ [ -n "$raddr" ] && {
+ append args "--ptr-record=$raddr,$fqdn"
+ raddr=""
+ }
done
}