aboutsummaryrefslogtreecommitdiffstats
path: root/package/dnsmasq
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-11-21 13:53:27 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-11-21 13:53:27 +0000
commit1918a94f1d231883bc7f10baa411112e32f17460 (patch)
treefb11e0a0555d3f376cacad32e923e73b996922e3 /package/dnsmasq
parent0bf1d404de4a907f3e8453506143137ba4a497c9 (diff)
downloadupstream-1918a94f1d231883bc7f10baa411112e32f17460.tar.gz
upstream-1918a94f1d231883bc7f10baa411112e32f17460.tar.bz2
upstream-1918a94f1d231883bc7f10baa411112e32f17460.zip
[PATCH] Package dnsmasq init-file
If an already running DHCP-server is found on the configured interface, the init-script refuses to start, but does not give a hint why. It took us some days to track down this behavior in our MANET, where every wifi/adhoc-node runs it own DHCP-server. Now syslog is more verbose on this. Signed-off-by: Bastian Bittorf <bittorf@bluebottle.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24051 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/dnsmasq')
-rw-r--r--package/dnsmasq/Makefile2
-rw-r--r--package/dnsmasq/files/dnsmasq.init9
2 files changed, 8 insertions, 3 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index 695d26088b..14d3cc4dd6 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_VERSION:=2.55
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
diff --git a/package/dnsmasq/files/dnsmasq.init b/package/dnsmasq/files/dnsmasq.init
index 00882e5f51..4acba5b846 100644
--- a/package/dnsmasq/files/dnsmasq.init
+++ b/package/dnsmasq/files/dnsmasq.init
@@ -271,7 +271,7 @@ dhcp_add() {
DNS_SERVERS="$DNS_SERVERS $dnsserver"
}
- append_bool "$cfg" ignore "-2 '$ifname'" && return 0
+ append_bool "$cfg" ignore "-2 $ifname" && return 0
config_get proto "$net" proto
[ static = "$proto" ] || return 0
@@ -283,7 +283,12 @@ dhcp_add() {
#check for an already active dhcp server on the interface, unless 'force' is set
config_get_bool force "$cfg" force 0
[ $force -gt 0 ] || {
- udhcpc -n -q -s /bin/true -t 1 -i $ifname >&- && return 0
+ udhcpc -n -q -s /bin/true -t 1 -i $ifname >&- && {
+ logger -t dnsmasq \
+ "found already running DHCP-server on interface '$ifname'" \
+ "refusing to start, use 'option force 1' to override"
+ return 0
+ }
}
config_get start "$cfg" start