aboutsummaryrefslogtreecommitdiffstats
path: root/package/dnsmasq/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-05-10 19:06:22 +0000
committerMike Baker <mbm@openwrt.org>2006-05-10 19:06:22 +0000
commit4db966cb5e50b72afbb0b0b9ea0176b78f4e9064 (patch)
tree723775516af9d2f501e52b4cbccb4b00f52ce5a9 /package/dnsmasq/Makefile
parenta9b90461ebdaeec297893bb2357a5785424f5844 (diff)
downloadupstream-4db966cb5e50b72afbb0b0b9ea0176b78f4e9064.tar.gz
upstream-4db966cb5e50b72afbb0b0b9ea0176b78f4e9064.tar.bz2
upstream-4db966cb5e50b72afbb0b0b9ea0176b78f4e9064.zip
Convert packages to new template
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3752 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/dnsmasq/Makefile')
-rw-r--r--package/dnsmasq/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index 19c6d35627..76b1ac0d99 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -25,13 +25,11 @@ URL:=http://www.thekelleys.org.uk/dnsmasq/
endef
define Package/dnsmasq/install
- install -d -m0755 $(IDIR_DNSMASQ)/usr/sbin
- install -d -m0755 $(IDIR_DNSMASQ)/etc/init.d/
+ install -m0755 -d $(IDIR_DNSMASQ)/usr/sbin
+ install -m0755 -d $(IDIR_DNSMASQ)/etc/init.d/
install -m0755 $(PKG_BUILD_DIR)/src/dnsmasq $(IDIR_DNSMASQ)/usr/sbin/
install -m0644 ./files/dnsmasq.conf $(IDIR_DNSMASQ)/etc/dnsmasq.conf
install -m0755 ./files/dnsmasq.init $(IDIR_DNSMASQ)/etc/init.d/S50dnsmasq
- $(RSTRIP) $(IDIR_DNSMASQ)
- $(IPKG_BUILD) $(IDIR_DNSMASQ) $(PACKAGE_DIR)
endef
$(eval $(call BuildPackage,dnsmasq))