aboutsummaryrefslogtreecommitdiffstats
path: root/package/dnsmasq/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
commitc2211dc51e98fa27d565c44179c3044723e69253 (patch)
treed97c293836c481a19206daabf6f6dd18c5a1e2d3 /package/dnsmasq/Makefile
parentd48cc978a7c8c0b6466eec7bf063f78a99e287cb (diff)
downloadupstream-c2211dc51e98fa27d565c44179c3044723e69253.tar.gz
upstream-c2211dc51e98fa27d565c44179c3044723e69253.tar.bz2
upstream-c2211dc51e98fa27d565c44179c3044723e69253.zip
replace lots of manual install commands with INSTALL_* variables
SVN-Revision: 5624
Diffstat (limited to 'package/dnsmasq/Makefile')
-rw-r--r--package/dnsmasq/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index e4d73332fd..e6af5672fa 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -43,12 +43,12 @@ define Build/Compile
endef
define Package/dnsmasq/install
- install -m0755 -d $(1)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
- install -m0755 -d $(1)/etc
- install -m0644 ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
- install -m0755 -d $(1)/etc/init.d
- install -m0755 ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/etc
+ $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
endef
$(eval $(call BuildPackage,dnsmasq))