aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorRui Salvaterra <rsalvaterra@gmail.com>2022-05-23 10:59:30 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-06-27 00:57:15 +0200
commitd075bb3f4a5317fa403cc8fa11bd561607ea6b71 (patch)
tree6df069f76eff6d8a36096abc1a5a477fee8c1c48 /package/devel
parente21fea92891fbdfb4eb14e9fe836530b6225cb1f (diff)
downloadupstream-d075bb3f4a5317fa403cc8fa11bd561607ea6b71.tar.gz
upstream-d075bb3f4a5317fa403cc8fa11bd561607ea6b71.tar.bz2
upstream-d075bb3f4a5317fa403cc8fa11bd561607ea6b71.zip
valgrind: bump to 3.19.0
Patches automatically rebased. Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/valgrind/Makefile4
-rw-r--r--package/devel/valgrind/patches/100-fix_configure_check.patch2
-rw-r--r--package/devel/valgrind/patches/130-fix_arm_arch_detection.patch2
-rw-r--r--package/devel/valgrind/patches/130-mips_fix_soft_float.patch4
4 files changed, 6 insertions, 6 deletions
diff --git a/package/devel/valgrind/Makefile b/package/devel/valgrind/Makefile
index e6ebff4b30..270aab6dba 100644
--- a/package/devel/valgrind/Makefile
+++ b/package/devel/valgrind/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=valgrind
-PKG_VERSION:=3.18.1
+PKG_VERSION:=3.19.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://sourceware.org/pub/valgrind/
-PKG_HASH:=00859aa13a772eddf7822225f4b46ee0d39afbe071d32778da4d99984081f7f5
+PKG_HASH:=dd5e34486f1a483ff7be7300cc16b4d6b24690987877c3278d797534d6738f02
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=GPL-2.0+
diff --git a/package/devel/valgrind/patches/100-fix_configure_check.patch b/package/devel/valgrind/patches/100-fix_configure_check.patch
index 6e9384ff88..38269bb14c 100644
--- a/package/devel/valgrind/patches/100-fix_configure_check.patch
+++ b/package/devel/valgrind/patches/100-fix_configure_check.patch
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -345,7 +345,7 @@ case "${host_os}" in
+@@ -368,7 +368,7 @@ case "${host_os}" in
# Ok, this is linux. Check the kernel version
AC_MSG_CHECKING([for the kernel version])
diff --git a/package/devel/valgrind/patches/130-fix_arm_arch_detection.patch b/package/devel/valgrind/patches/130-fix_arm_arch_detection.patch
index 26291f777b..957e5c930f 100644
--- a/package/devel/valgrind/patches/130-fix_arm_arch_detection.patch
+++ b/package/devel/valgrind/patches/130-fix_arm_arch_detection.patch
@@ -6,7 +6,7 @@ Last-Update: 2013-11-30
--- a/configure.ac
+++ b/configure.ac
-@@ -252,7 +252,7 @@ case "${host_cpu}" in
+@@ -275,7 +275,7 @@ case "${host_cpu}" in
ARCH_MAX="s390x"
;;
diff --git a/package/devel/valgrind/patches/130-mips_fix_soft_float.patch b/package/devel/valgrind/patches/130-mips_fix_soft_float.patch
index 427aa85524..9d3482815c 100644
--- a/package/devel/valgrind/patches/130-mips_fix_soft_float.patch
+++ b/package/devel/valgrind/patches/130-mips_fix_soft_float.patch
@@ -48,7 +48,7 @@ This fixes the following error message when compiling with a GCC 10 MIPS BE 32:
--- a/coregrind/m_machine.c
+++ b/coregrind/m_machine.c
-@@ -2103,6 +2103,7 @@ Bool VG_(machine_get_hwcaps)( void )
+@@ -2106,6 +2106,7 @@ Bool VG_(machine_get_hwcaps)( void )
we are using alternative way to determine FP mode */
ULong result = 0;
@@ -56,7 +56,7 @@ This fixes the following error message when compiling with a GCC 10 MIPS BE 32:
if (!VG_MINIMAL_SETJMP(env_unsup_insn)) {
__asm__ volatile (
".set push\n\t"
-@@ -2120,6 +2121,9 @@ Bool VG_(machine_get_hwcaps)( void )
+@@ -2123,6 +2124,9 @@ Bool VG_(machine_get_hwcaps)( void )
fpmode = (result != 0x3FF0000000000000ull);
}