aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2018-06-28 13:00:10 +0300
committerJo-Philipp Wich <jo@mein.io>2018-12-18 11:28:12 +0100
commit0dbafc3a3a9becad5b50e9c2f8c86cc9eac0bfba (patch)
tree176f92a095ae4e0fa3602e90034e8a45ca2c5669 /package/devel
parent8cac88af4b0f30586cd848a8543e7b1f81902d6b (diff)
downloadupstream-0dbafc3a3a9becad5b50e9c2f8c86cc9eac0bfba.tar.gz
upstream-0dbafc3a3a9becad5b50e9c2f8c86cc9eac0bfba.tar.bz2
upstream-0dbafc3a3a9becad5b50e9c2f8c86cc9eac0bfba.zip
strace: fix build on aarch64
As of version 4.21, strace enforces mpers by default. The current implementation of aarch64 compat in strace assumes it's identical to ARMv7 EABI and therefore tries to enable m32 personality support. As there is no -m32 support on aarch64, this causes the build to fail. Restore previous strace behavior to fix build on aarch64. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Tested-by: Karl Palsson <karlp@tweak.net.au> (backported from 067e2f5f1d0102ffb96d3248e42a29e7352cc29c)
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/strace/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/devel/strace/Makefile b/package/devel/strace/Makefile
index 6209dc5a63..15faa5e406 100644
--- a/package/devel/strace/Makefile
+++ b/package/devel/strace/Makefile
@@ -30,6 +30,10 @@ include $(INCLUDE_DIR)/package.mk
HOST_CFLAGS += -I$(LINUX_DIR)/user_headers/include
+ifeq ($(ARCH),aarch64)
+ CONFIGURE_ARGS += --enable-mpers=check
+endif
+
CONFIGURE_VARS+= \
LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
CPPFLAGS_FOR_BUILD="$(HOST_CPPFLAGS)" \