aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-08-03 11:15:47 +0000
committerJohn Crispin <blogic@openwrt.org>2014-08-03 11:15:47 +0000
commitf2fb930c985be9435f80e0a16518488ee18f6fc4 (patch)
treecee53bbba697fc15aca9594e9068d43704fdd432 /package/devel
parent486543b227b509ad3fabf43a590126482302c6cb (diff)
downloadupstream-f2fb930c985be9435f80e0a16518488ee18f6fc4.tar.gz
upstream-f2fb930c985be9435f80e0a16518488ee18f6fc4.tar.bz2
upstream-f2fb930c985be9435f80e0a16518488ee18f6fc4.zip
valgrind: add x86_64 support
Signed-off-by: Alexandru Ardelean <aa@ocedo.com> Backport of r41934 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@41974 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/valgrind/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/package/devel/valgrind/Makefile b/package/devel/valgrind/Makefile
index 6c22348cff..a55fb40d80 100644
--- a/package/devel/valgrind/Makefile
+++ b/package/devel/valgrind/Makefile
@@ -28,7 +28,7 @@ include $(INCLUDE_DIR)/kernel.mk
define Package/valgrind
SECTION:=devel
CATEGORY:=Development
- DEPENDS:=@mips||mipsel||i386||powerpc||arm_v7 +libpthread +librt
+ DEPENDS:=@mips||mipsel||i386||x86_64||powerpc||arm_v7 +libpthread +librt
TITLE:=debugging and profiling tools for Linux
URL:=http://www.valgrind.org
endef
@@ -77,13 +77,20 @@ define Package/valgrind/description
to speed up and reduce memory use of your programs.
endef
-CPU := $(patsubst x86,i386,$(LINUX_KARCH))
+CPU := $(patsubst x86_64,amd64,$(patsubst x86,i386,$(LINUX_KARCH)))
CONFIGURE_VARS += \
UNAME_R=$(LINUX_VERSION)
+ifeq ($(ARCH),x86_64)
+ BITS := 64bit
+else
+ CONFIGURE_ARGS += \
+ --enable-only32bit
+ BITS := 32bit
+endif
+
CONFIGURE_ARGS += \
- --enable-only32bit \
--enable-tls \
--without-x \
--without-uiout \
@@ -101,8 +108,8 @@ define Package/valgrind/install
$(PKG_INSTALL_DIR)/usr/lib/valgrind/none-* \
$(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_core*.so \
$(PKG_INSTALL_DIR)/usr/lib/valgrind/$(CPU)-*.xml \
- $(PKG_INSTALL_DIR)/usr/lib/valgrind/32bit-core*.xml \
- $(PKG_INSTALL_DIR)/usr/lib/valgrind/32bit-linux*.xml \
+ $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(BITS)-core*.xml \
+ $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(BITS)-linux*.xml \
$(PKG_INSTALL_DIR)/usr/lib/valgrind/memcheck-* \
$(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_memcheck*.so \
$(1)/usr/lib/valgrind/