aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-07-03 17:23:55 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-07-03 17:23:55 +0000
commit426c0e060b520e066fe5aaddcee9d5917b390f2f (patch)
treef675f052fba89ae1441a022f29a3ae5a232c03ac /package/devel
parentd867d5982116fdd7cbfecfb822eb9e5aa3ce0838 (diff)
downloadupstream-426c0e060b520e066fe5aaddcee9d5917b390f2f.tar.gz
upstream-426c0e060b520e066fe5aaddcee9d5917b390f2f.tar.bz2
upstream-426c0e060b520e066fe5aaddcee9d5917b390f2f.zip
trace-cmd: remove the compile fix patch
And instead override TARGET_CFLAGS to set _GNU_SOURCE accordingly since this is the upstream maintainer solution. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37152 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/devel')
-rw-r--r--package/devel/trace-cmd/Makefile2
-rw-r--r--package/devel/trace-cmd/patches/100-compile_fix.patch20
2 files changed, 1 insertions, 21 deletions
diff --git a/package/devel/trace-cmd/Makefile b/package/devel/trace-cmd/Makefile
index 5263841aac..f7c211f0c9 100644
--- a/package/devel/trace-cmd/Makefile
+++ b/package/devel/trace-cmd/Makefile
@@ -37,7 +37,7 @@ MAKE_FLAGS += \
PLUGINS_DIR := $(PKG_INSTALL_DIR)/usr/lib/trace-cmd/plugins
PLUGINS_MAIN := function hrtimer mac80211 sched_switch
-TARGET_CFLAGS += --std=gnu99
+TARGET_CFLAGS += --std=gnu99 -D_GNU_SOURCE
define Package/trace-cmd/install
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib/trace-cmd/plugins
diff --git a/package/devel/trace-cmd/patches/100-compile_fix.patch b/package/devel/trace-cmd/patches/100-compile_fix.patch
deleted file mode 100644
index d0f34f93ff..0000000000
--- a/package/devel/trace-cmd/patches/100-compile_fix.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/trace-listen.c
-+++ b/trace-listen.c
-@@ -17,6 +17,7 @@
- *
- * ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
- */
-+#define _GNU_SOURCE
- #define _LARGEFILE64_SOURCE
- #include <dirent.h>
- #include <stdio.h>
---- a/trace-record.c
-+++ b/trace-record.c
-@@ -17,6 +17,7 @@
- *
- * ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
- */
-+#define _GNU_SOURCE
- #include <dirent.h>
- #include <stdio.h>
- #include <stdlib.h>