aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel/gdb
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2021-11-07 17:14:16 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-11-07 18:32:21 +0100
commit84616a1725ad274852a7bb016c25653627505714 (patch)
treea31f5d082a936465e06cec3fdb6f5862da914fce /package/devel/gdb
parent184d072fc0d4fd2721e66abf00c985f4477c6a09 (diff)
downloadupstream-84616a1725ad274852a7bb016c25653627505714.tar.gz
upstream-84616a1725ad274852a7bb016c25653627505714.tar.bz2
upstream-84616a1725ad274852a7bb016c25653627505714.zip
gdb: Add explicit patch to libgmp
Without giving the patch gdb does not compile on Arch Linux. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/devel/gdb')
-rw-r--r--package/devel/gdb/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/devel/gdb/Makefile b/package/devel/gdb/Makefile
index 9e20644b04..f474502869 100644
--- a/package/devel/gdb/Makefile
+++ b/package/devel/gdb/Makefile
@@ -62,7 +62,11 @@ CONFIGURE_ARGS+= \
--disable-ubsan \
--disable-sim \
--disable-werror \
- --disable-source-highlight
+ --disable-source-highlight \
+ --without-mpc \
+ --without-mpfr \
+ --without-isl \
+ --with-libgmp-prefix=$(STAGING_DIR)/usr
CONFIGURE_VARS+= \
ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"