aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel/binutils/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2023-02-26 15:47:09 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-03-05 19:23:42 +0100
commita03076cc392b67c8342aac2017f8ac903c983e59 (patch)
tree542fb1591eff700914429db79fce87aef9fb48bc /package/devel/binutils/Makefile
parent26a65e852c5bd8e586205ce8dff582de623cb566 (diff)
downloadupstream-a03076cc392b67c8342aac2017f8ac903c983e59.tar.gz
upstream-a03076cc392b67c8342aac2017f8ac903c983e59.tar.bz2
upstream-a03076cc392b67c8342aac2017f8ac903c983e59.zip
binutils: Update to version 2.40
binutils 2.39: https://lists.gnu.org/archive/html/info-gnu/2022-08/msg00002.html binutils 2.40: https://lists.gnu.org/archive/html/info-gnu/2023-01/msg00003.html This version includes a new libsframe.so library, pack it into the libbfd package as it is used by this library. Also deactivate some optional configuration options for now. An extra patch to fix compile problem in AARCH64 is added. gprofng needs a C++ standard library, deactivate it for now. Activate feature-disassembler-init-styled in bpftools too to fix compilation with the updated binutils. An bpftool version 7.0 or later is needed for binutils 2.39 and later. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/devel/binutils/Makefile')
-rw-r--r--package/devel/binutils/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/package/devel/binutils/Makefile b/package/devel/binutils/Makefile
index 75fdd320cd..95939f2dcd 100644
--- a/package/devel/binutils/Makefile
+++ b/package/devel/binutils/Makefile
@@ -8,16 +8,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=binutils
-PKG_VERSION:=2.38
+PKG_VERSION:=2.40
PKG_RELEASE:=1
PKG_SOURCE_URL:=@GNU/binutils
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_VERSION:=$(PKG_VERSION)
-PKG_HASH:=e316477a914f567eccc34d5d29785b8b0f5a10208d36bbacedcc39048ecfe024
+PKG_HASH:=0f8a4c272d7f17f369ded10a4aca28b8e304828e95526da482b0ccc4dfc9d8e1
PKG_FIXUP:=patch-libtool
-PKG_LIBTOOL_PATHS:=. gas bfd opcodes gprof binutils ld libiberty gold intl
+PKG_LIBTOOL_PATHS:=. gas bfd opcodes gprof gprofng binutils ld libiberty gold intl libctf libsframe
PKG_REMOVE_FILES:=libtool.m4
PKG_INSTALL:=1
@@ -87,7 +87,10 @@ CONFIGURE_ARGS += \
--enable-shared \
--enable-install-libiberty \
--enable-install-libbfd \
- --enable-install-libctf
+ --enable-install-libctf \
+ --with-system-zlib \
+ --without-zstd \
+ --disable-gprofng
define Build/Install
$(call Build/Install/Default)
@@ -105,6 +108,7 @@ endef
define Package/libbfd/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libbfd*.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsframe*.so* $(1)/usr/lib/
endef
define Package/libctf/install