aboutsummaryrefslogtreecommitdiffstats
path: root/package/cyassl/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-03-25 16:03:10 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-03-25 16:03:10 +0000
commitd23e5b2dd9a1c674868959113e58f3cc1963facf (patch)
tree28f07adc208cd7b3789125dcc04d7bc0a3fa39f3 /package/cyassl/Makefile
parent960a327a19e605f16bc5778d1e551eeba65f4680 (diff)
downloadupstream-d23e5b2dd9a1c674868959113e58f3cc1963facf.tar.gz
upstream-d23e5b2dd9a1c674868959113e58f3cc1963facf.tar.bz2
upstream-d23e5b2dd9a1c674868959113e58f3cc1963facf.zip
[package] add cyassl (moved from packages feed, required by uhttpd-mod-tls)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20430 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/cyassl/Makefile')
-rw-r--r--package/cyassl/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/package/cyassl/Makefile b/package/cyassl/Makefile
new file mode 100644
index 0000000000..af4bc269bb
--- /dev/null
+++ b/package/cyassl/Makefile
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cyassl
+PKG_VERSION:=1.4.0
+PKG_RELEASE:=2
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
+PKG_SOURCE_URL:=http://www.yassl.com/
+PKG_MD5SUM:=037397c7df84b9a12e614bf46135df1c
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libcyassl
+ SECTION:=libs
+ SUBMENU:=SSL
+ CATEGORY:=Libraries
+ DEPENDS:=+zlib
+ TITLE:=CyaSSL library
+ URL:=http://www.yassl.com/
+endef
+
+define Package/libcyassl/description
+CyaSSL is an SSL library optimized for small footprint, both on disk and for
+memory use.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --without-zlib \
+ --enable-singleThreaded
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.{a,so*,la} $(1)/usr/lib/
+endef
+
+define Package/libcyassl/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libcyassl))