aboutsummaryrefslogtreecommitdiffstats
path: root/package/crda/patches/101-make_crypto_use_optional.patch
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-01-30 15:48:35 +0000
committerNicolas Thill <nico@openwrt.org>2009-01-30 15:48:35 +0000
commitc52f0bfe0bb6d8a6c17752a2d9222a00cd1096f1 (patch)
treef437bacc36cf73dddadfd3f7964d1da92d010080 /package/crda/patches/101-make_crypto_use_optional.patch
parentb065bc53101e7460f29e3743e67673205fc82ebf (diff)
downloadupstream-c52f0bfe0bb6d8a6c17752a2d9222a00cd1096f1.tar.gz
upstream-c52f0bfe0bb6d8a6c17752a2d9222a00cd1096f1.tar.bz2
upstream-c52f0bfe0bb6d8a6c17752a2d9222a00cd1096f1.zip
crda: make the whole crypto stuff optional and don't use it for now, link statically with libnl
SVN-Revision: 14284
Diffstat (limited to 'package/crda/patches/101-make_crypto_use_optional.patch')
-rw-r--r--package/crda/patches/101-make_crypto_use_optional.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/crda/patches/101-make_crypto_use_optional.patch b/package/crda/patches/101-make_crypto_use_optional.patch
new file mode 100644
index 0000000000..105ffb36e7
--- /dev/null
+++ b/package/crda/patches/101-make_crypto_use_optional.patch
@@ -0,0 +1,13 @@
+--- a/Makefile
++++ b/Makefile
+@@ -29,7 +29,9 @@ LDLIBS += `pkg-config --libs openssl`
+
+ reglib.o: keys-ssl.c
+
+-else
++endif
++
++ifeq ($(USE_GCRYPT),1)
+ CFLAGS += -DUSE_GCRYPT
+ LDLIBS += -lgcrypt
+