aboutsummaryrefslogtreecommitdiffstats
path: root/package/crda/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-01-30 15:48:35 +0000
committerNicolas Thill <nico@openwrt.org>2009-01-30 15:48:35 +0000
commitc52f0bfe0bb6d8a6c17752a2d9222a00cd1096f1 (patch)
treef437bacc36cf73dddadfd3f7964d1da92d010080 /package/crda/Makefile
parentb065bc53101e7460f29e3743e67673205fc82ebf (diff)
downloadupstream-c52f0bfe0bb6d8a6c17752a2d9222a00cd1096f1.tar.gz
upstream-c52f0bfe0bb6d8a6c17752a2d9222a00cd1096f1.tar.bz2
upstream-c52f0bfe0bb6d8a6c17752a2d9222a00cd1096f1.zip
crda: make the whole crypto stuff optional and don't use it for now, link statically with libnl
SVN-Revision: 14284
Diffstat (limited to 'package/crda/Makefile')
-rw-r--r--package/crda/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/crda/Makefile b/package/crda/Makefile
index aa58524ec2..5b7b0accfc 100644
--- a/package/crda/Makefile
+++ b/package/crda/Makefile
@@ -15,7 +15,7 @@ PKG_VERSION:=1.0.1
PKG_SOURCE_URL:=http://wireless.kernel.org/download/crda
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_MD5SUM:=03554b71eef2626795befa17eb1d8b9e
-PKG_BUILD_DEPENDS:=mac80211 libnl openssl
+PKG_BUILD_DEPENDS:=mac80211 libnl
PKG_REGULATORY_NAME:=regulatory
PKG_REGULATORY_VERSION:=2009.01.15
@@ -54,9 +54,9 @@ define Build/Compile
$(MAKE_VARS) \
$(MAKE) -C $(PKG_BUILD_DIR)/$(MAKE_PATH) \
$(MAKE_FLAGS) \
- USE_OPENSSL=1 \
+ NLLIBS="$(STAGING_DIR)/usr/lib/libnl.a -lm" \
REG_BIN="$(DL_DIR)/$(PKG_REGULATORY_SOURCE)" \
- $(1)
+ crda
endef
define Package/crda/install