aboutsummaryrefslogtreecommitdiffstats
path: root/package/compcache
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-16 09:54:27 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-16 09:54:27 +0000
commitc15df46407000caf055327c52a0ba00a35a0a394 (patch)
tree842aa818824f8a3ac70fb9ec2d1009bdf51aa045 /package/compcache
parent4a2993fc17d0099943d30fb97a47f333261e948c (diff)
downloadupstream-c15df46407000caf055327c52a0ba00a35a0a394.tar.gz
upstream-c15df46407000caf055327c52a0ba00a35a0a394.tar.bz2
upstream-c15df46407000caf055327c52a0ba00a35a0a394.zip
package/compcache: move configuration in submenu
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20906 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/compcache')
-rw-r--r--package/compcache/Config.in7
-rw-r--r--package/compcache/Makefile1
2 files changed, 4 insertions, 4 deletions
diff --git a/package/compcache/Config.in b/package/compcache/Config.in
index 9904237edc..11a94d4342 100644
--- a/package/compcache/Config.in
+++ b/package/compcache/Config.in
@@ -1,15 +1,14 @@
-# compcache configuration
+menu "Configuration"
+ depends on PACKAGE_kmod-compcache
config COMPCACHE_ENABLE
bool "enabled on boot"
default n
- depends on PACKAGE_kmod-compcache
help
Enables compressed ram swap devices.
config COMPCACHE_RAM_REPORTED
string "swap space reported to kernel in kb"
- depends on PACKAGE_kmod-compcache
default "2048"
help
This is the amount of memory that will be reported
@@ -21,10 +20,10 @@ config COMPCACHE_RAM_REPORTED
config COMPCACHE_BACKUP_DEV
string "Backup device for compcache"
- depends on PACKAGE_kmod-compcache
default ""
help
Compcache will use this as a backup device for swap.
Example:
/dev/sda5
+endmenu
diff --git a/package/compcache/Makefile b/package/compcache/Makefile
index 2fec289527..13a9056db4 100644
--- a/package/compcache/Makefile
+++ b/package/compcache/Makefile
@@ -26,6 +26,7 @@ define KernelPackage/compcache
VERSION:=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)+$(PKG_RELEASE)
FILES:=$(PKG_BUILD_DIR)/ramzswap.$(LINUX_KMOD_SUFFIX) \
$(PKG_BUILD_DIR)/sub-projects/compression/lzo-kmod/lzo1x.$(LINUX_KMOD_SUFFIX)
+ MENU:=1
endef