aboutsummaryrefslogtreecommitdiffstats
path: root/package/comgt
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-02-19 11:17:13 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-02-19 11:17:13 +0000
commitbbb3cb3a3c1892b0e57cd5b340db3f70ef30bd60 (patch)
treefb18343371b977e594fd3c4f16d4eb196b99e100 /package/comgt
parentdd42dcb5014c7e43539f590cde105b50dcef70f5 (diff)
downloadupstream-bbb3cb3a3c1892b0e57cd5b340db3f70ef30bd60.tar.gz
upstream-bbb3cb3a3c1892b0e57cd5b340db3f70ef30bd60.tar.bz2
upstream-bbb3cb3a3c1892b0e57cd5b340db3f70ef30bd60.zip
Upgrade comgt to 0.32 (#1347)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6323 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/comgt')
-rw-r--r--package/comgt/Makefile13
-rw-r--r--package/comgt/patches/001-Makefile.patch158
2 files changed, 132 insertions, 39 deletions
diff --git a/package/comgt/Makefile b/package/comgt/Makefile
index d22b72c53a..4131fc23f4 100644
--- a/package/comgt/Makefile
+++ b/package/comgt/Makefile
@@ -9,19 +9,18 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=comgt
-PKG_VERSION:=0.3
+PKG_VERSION:=0.32
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION).tgz
-PKG_SOURCE_URL:=http://www.pharscape.org/3G/comgt
-PKG_MD5SUM:=cd32663025ed94a0ee623a689989f3c3
+PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=@SF/comgt
+PKG_MD5SUM:=db2452680c3d953631299e331daf49ef
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_UNPACK:=mkdir -p $(PKG_BUILD_DIR); zcat $(DL_DIR)/$(PKG_SOURCE) | $(TAR) -C $(PKG_BUILD_DIR) $(TAR_OPTIONS)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME).$(PKG_VERSION)
+PKG_CAT:=zcat
include $(INCLUDE_DIR)/package.mk
-
define Package/comgt
SECTION:=utils
CATEGORY:=Utilities
diff --git a/package/comgt/patches/001-Makefile.patch b/package/comgt/patches/001-Makefile.patch
index 28ea2ecf27..c3723fa463 100644
--- a/package/comgt/patches/001-Makefile.patch
+++ b/package/comgt/patches/001-Makefile.patch
@@ -1,32 +1,126 @@
---- gcom-0.3.x/Makefile 2006-01-04 17:05:28.000000000 +0200
-+++ gcom-0.3/Makefile 2006-02-26 13:02:07.000000000 +0200
-@@ -20,8 +20,6 @@
- #
- # $Id$
- #
--LIB = -L/usr/local/lib
--INC = -I/usr/local/include
- EXE = /usr/local/bin
- MAN = /usr/share/man/man1
- CPROG = gcom
-@@ -29,9 +27,6 @@
- BIN = $(CPROG) $(SCRIPT)
- MANP = gcom.1 sigmon.1
-
--CFLAGS = -c
--LDFLAGS =
--
- all: $(BIN)
-
- install:
-@@ -53,8 +48,8 @@
-
-
- gcom: gcom.o
-- cc gcom.o $(LDFLAGS) -o gcom
-+ $(CC) gcom.o $(LDFLAGS) -o gcom
-
- gcom.o: gcom.c gcom.h
-- cc gcom.c $(CFLAGS)
-+ $(CC) -c $(CFLAGS) gcom.c
-
+diff -rhNp comgt.0.32/Makefile gcom-032/Makefile
+*** comgt.0.32/Makefile 2007-02-10 19:07:58.723709368 +0100
+--- gcom-032/Makefile 2007-02-10 19:18:26.764232696 +0100
+***************
+*** 1,7 ****
+ #
+! # Makefile - build and install the comgt package
+ # Copyright (C) 2005 Martin Gregorie
+- # Copyright (C) 2006 Paul Hardwick
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+--- 1,6 ----
+ #
+! # Makefile - build and install the gmon package
+ # Copyright (C) 2005 Martin Gregorie
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+***************
+*** 17,79 ****
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ #
+! # martin@gregorie.org, paul@peck.org.uk
+ #
+! # $Id: Makefile,v 1.4 2006/10/20 14:30:19 pharscape Exp $
+ #
+- #
+-
+- LIB = -L/usr/local/lib
+- INC = -I/usr/local/include
+ EXE = /usr/local/bin
+ MAN = /usr/share/man/man1
+! CPROG = comgt
+! SCRIPTPATH = /etc/comgt/
+! SCRIPTSRC = ./scripts/
+! BIN = $(CPROG)
+! MANP = comgt.1 sigmon.1
+!
+! CFLAGS = -c
+! LDFLAGS =
+
+ all: $(BIN)
+
+ install:
+ chmod a-w $(BIN)
+ chmod u+rw $(BIN)
+ chmod a+x $(BIN)
+! cp $(BIN) $(EXE)
+ chmod a-wx $(MANP)
+ chmod u+rw $(MANP)
+ chmod a+r $(MANP)
+ cp $(MANP) $(MAN)
+- -mkdir $(SCRIPTPATH)
+- chmod a-w $(SCRIPTPATH)
+- chmod u+rw $(SCRIPTPATH)
+- chmod a+x $(SCRIPTPATH)
+- cp -f $(SCRIPTSRC)* $(SCRIPTPATH)
+- chmod a-w $(SCRIPTPATH)*
+- chmod u+rw $(SCRIPTPATH)*
+- chmod a+x $(SCRIPTPATH)*
+-
+-
+-
+
+ uninstall:
+ cd $(EXE); rm $(BIN)
+ cd $(MAN); rm $(MANP)
+- -rm -r $(SCRIPTPATH)
+
+ clean:
+! -rm *.o
+! -rm $(CPROG)
+! -rm *~
+! -rm $(SCRIPTSRC)*~
+
+
+! comgt: comgt.o
+! cc comgt.o $(LDFLAGS) -o comgt
+
+! comgt.o: comgt.c comgt.h
+! cc comgt.c $(CFLAGS)
+
+--- 16,56 ----
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ #
+! # martin@gregorie.org
+ #
+! # $Id$
+ #
+ EXE = /usr/local/bin
+ MAN = /usr/share/man/man1
+! CPROG = gcom
+! SCRIPT = sigmon
+! BIN = $(CPROG) $(SCRIPT)
+! MANP = gcom.1 sigmon.1
+
+ all: $(BIN)
+
+ install:
++ mv ($BIN} {$BIN2}
+ chmod a-w $(BIN)
+ chmod u+rw $(BIN)
+ chmod a+x $(BIN)
+! cp $(BIN) $(EXE)/gcom
+ chmod a-wx $(MANP)
+ chmod u+rw $(MANP)
+ chmod a+r $(MANP)
+ cp $(MANP) $(MAN)
+
+ uninstall:
+ cd $(EXE); rm $(BIN)
+ cd $(MAN); rm $(MANP)
+
+ clean:
+! rm *.o $(CPROG)
+
+
+! gcom: gcom.o
+! $(CC) gcom.o $(LDFLAGS) -o gcom
+
+! gcom.o: comgt.c comgt.h
+! $(CC) -c $(CFLAGS) comgt.c -o gcom.o
+