aboutsummaryrefslogtreecommitdiffstats
path: root/package/comgt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-04 11:25:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-04 11:25:53 +0000
commit12a81e859f38f85f5143e72b56b5a1f974c53576 (patch)
treeb2d994878969d3f9d2d56625fccda64c5ac25e8a /package/comgt
parentac587815b0f46cdc8eb7d7141ffb5784b98b4b3b (diff)
downloadupstream-12a81e859f38f85f5143e72b56b5a1f974c53576.tar.gz
upstream-12a81e859f38f85f5143e72b56b5a1f974c53576.tar.bz2
upstream-12a81e859f38f85f5143e72b56b5a1f974c53576.zip
refresh all package patches in the buildroot using quilt
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7490 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/comgt')
-rw-r--r--package/comgt/patches/001-Makefile.patch216
1 files changed, 90 insertions, 126 deletions
diff --git a/package/comgt/patches/001-Makefile.patch b/package/comgt/patches/001-Makefile.patch
index c3723fa463..32b56b12b7 100644
--- a/package/comgt/patches/001-Makefile.patch
+++ b/package/comgt/patches/001-Makefile.patch
@@ -1,126 +1,90 @@
-diff -rhNp comgt.0.32/Makefile gcom-032/Makefile
-*** comgt.0.32/Makefile 2007-02-10 19:07:58.723709368 +0100
---- gcom-032/Makefile 2007-02-10 19:18:26.764232696 +0100
-***************
-*** 1,7 ****
- #
-! # Makefile - build and install the comgt package
- # Copyright (C) 2005 Martin Gregorie
-- # Copyright (C) 2006 Paul Hardwick
- #
- # This program is free software; you can redistribute it and/or modify
- # it under the terms of the GNU General Public License as published by
---- 1,6 ----
- #
-! # Makefile - build and install the gmon package
- # Copyright (C) 2005 Martin Gregorie
- #
- # This program is free software; you can redistribute it and/or modify
- # it under the terms of the GNU General Public License as published by
-***************
-*** 17,79 ****
- # along with this program; if not, write to the Free Software
- # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
- #
-! # martin@gregorie.org, paul@peck.org.uk
- #
-! # $Id: Makefile,v 1.4 2006/10/20 14:30:19 pharscape Exp $
- #
-- #
--
-- LIB = -L/usr/local/lib
-- INC = -I/usr/local/include
- EXE = /usr/local/bin
- MAN = /usr/share/man/man1
-! CPROG = comgt
-! SCRIPTPATH = /etc/comgt/
-! SCRIPTSRC = ./scripts/
-! BIN = $(CPROG)
-! MANP = comgt.1 sigmon.1
-!
-! CFLAGS = -c
-! LDFLAGS =
-
- all: $(BIN)
-
- install:
- chmod a-w $(BIN)
- chmod u+rw $(BIN)
- chmod a+x $(BIN)
-! cp $(BIN) $(EXE)
- chmod a-wx $(MANP)
- chmod u+rw $(MANP)
- chmod a+r $(MANP)
- cp $(MANP) $(MAN)
-- -mkdir $(SCRIPTPATH)
-- chmod a-w $(SCRIPTPATH)
-- chmod u+rw $(SCRIPTPATH)
-- chmod a+x $(SCRIPTPATH)
-- cp -f $(SCRIPTSRC)* $(SCRIPTPATH)
-- chmod a-w $(SCRIPTPATH)*
-- chmod u+rw $(SCRIPTPATH)*
-- chmod a+x $(SCRIPTPATH)*
--
--
--
-
- uninstall:
- cd $(EXE); rm $(BIN)
- cd $(MAN); rm $(MANP)
-- -rm -r $(SCRIPTPATH)
-
- clean:
-! -rm *.o
-! -rm $(CPROG)
-! -rm *~
-! -rm $(SCRIPTSRC)*~
-
-
-! comgt: comgt.o
-! cc comgt.o $(LDFLAGS) -o comgt
-
-! comgt.o: comgt.c comgt.h
-! cc comgt.c $(CFLAGS)
-
---- 16,56 ----
- # along with this program; if not, write to the Free Software
- # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
- #
-! # martin@gregorie.org
- #
-! # $Id$
- #
- EXE = /usr/local/bin
- MAN = /usr/share/man/man1
-! CPROG = gcom
-! SCRIPT = sigmon
-! BIN = $(CPROG) $(SCRIPT)
-! MANP = gcom.1 sigmon.1
-
- all: $(BIN)
-
- install:
-+ mv ($BIN} {$BIN2}
- chmod a-w $(BIN)
- chmod u+rw $(BIN)
- chmod a+x $(BIN)
-! cp $(BIN) $(EXE)/gcom
- chmod a-wx $(MANP)
- chmod u+rw $(MANP)
- chmod a+r $(MANP)
- cp $(MANP) $(MAN)
-
- uninstall:
- cd $(EXE); rm $(BIN)
- cd $(MAN); rm $(MANP)
-
- clean:
-! rm *.o $(CPROG)
-
-
-! gcom: gcom.o
-! $(CC) gcom.o $(LDFLAGS) -o gcom
-
-! gcom.o: comgt.c comgt.h
-! $(CC) -c $(CFLAGS) comgt.c -o gcom.o
-
+Index: comgt.0.32/Makefile
+===================================================================
+--- comgt.0.32.orig/Makefile 2007-06-04 13:22:22.665409616 +0200
++++ comgt.0.32/Makefile 2007-06-04 13:22:22.730399736 +0200
+@@ -1,7 +1,6 @@
+ #
+-# Makefile - build and install the comgt package
++# Makefile - build and install the gmon package
+ # Copyright (C) 2005 Martin Gregorie
+-# Copyright (C) 2006 Paul Hardwick
+ #
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+@@ -17,63 +16,41 @@
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ #
+-# martin@gregorie.org, paul@peck.org.uk
++# martin@gregorie.org
+ #
+-# $Id: Makefile,v 1.4 2006/10/20 14:30:19 pharscape Exp $
++# $Id$
+ #
+-#
+-
+-LIB = -L/usr/local/lib
+-INC = -I/usr/local/include
+ EXE = /usr/local/bin
+ MAN = /usr/share/man/man1
+-CPROG = comgt
+-SCRIPTPATH = /etc/comgt/
+-SCRIPTSRC = ./scripts/
+-BIN = $(CPROG)
+-MANP = comgt.1 sigmon.1
+-
+-CFLAGS = -c
+-LDFLAGS =
++CPROG = gcom
++SCRIPT = sigmon
++BIN = $(CPROG) $(SCRIPT)
++MANP = gcom.1 sigmon.1
+
+ all: $(BIN)
+
+ install:
++ mv ($BIN} {$BIN2}
+ chmod a-w $(BIN)
+ chmod u+rw $(BIN)
+ chmod a+x $(BIN)
+- cp $(BIN) $(EXE)
++ cp $(BIN) $(EXE)/gcom
+ chmod a-wx $(MANP)
+ chmod u+rw $(MANP)
+ chmod a+r $(MANP)
+ cp $(MANP) $(MAN)
+- -mkdir $(SCRIPTPATH)
+- chmod a-w $(SCRIPTPATH)
+- chmod u+rw $(SCRIPTPATH)
+- chmod a+x $(SCRIPTPATH)
+- cp -f $(SCRIPTSRC)* $(SCRIPTPATH)
+- chmod a-w $(SCRIPTPATH)*
+- chmod u+rw $(SCRIPTPATH)*
+- chmod a+x $(SCRIPTPATH)*
+-
+-
+-
+
+ uninstall:
+ cd $(EXE); rm $(BIN)
+ cd $(MAN); rm $(MANP)
+- -rm -r $(SCRIPTPATH)
+
+ clean:
+- -rm *.o
+- -rm $(CPROG)
+- -rm *~
+- -rm $(SCRIPTSRC)*~
++ rm *.o $(CPROG)
+
+
+-comgt: comgt.o
+- cc comgt.o $(LDFLAGS) -o comgt
++gcom: gcom.o
++ $(CC) gcom.o $(LDFLAGS) -o gcom
+
+-comgt.o: comgt.c comgt.h
+- cc comgt.c $(CFLAGS)
++gcom.o: comgt.c comgt.h
++ $(CC) -c $(CFLAGS) comgt.c -o gcom.o
+