aboutsummaryrefslogtreecommitdiffstats
path: root/package/chillispot
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-04-11 00:57:23 +0000
committerNicolas Thill <nico@openwrt.org>2005-04-11 00:57:23 +0000
commit68d942f0320308101ef2fe885de8324400f7feb0 (patch)
tree2627e7e0dea306b7d2f3c30b904b33e0b702480a /package/chillispot
parentf416b931d4647bf2123a017ae797ed62f0991c75 (diff)
downloadupstream-68d942f0320308101ef2fe885de8324400f7feb0.tar.gz
upstream-68d942f0320308101ef2fe885de8324400f7feb0.tar.bz2
upstream-68d942f0320308101ef2fe885de8324400f7feb0.zip
Fix chillispot configure and install
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@622 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/chillispot')
-rw-r--r--package/chillispot/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/package/chillispot/Makefile b/package/chillispot/Makefile
index 71736aedc3..454105d082 100644
--- a/package/chillispot/Makefile
+++ b/package/chillispot/Makefile
@@ -32,6 +32,8 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
+ --program-prefix="" \
+ --program-suffix="" \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
@@ -39,11 +41,12 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
--includedir=/usr/include \
--infodir=/usr/share/info \
--libdir=/usr/lib \
- --libexecdir=/usr/lib/locate \
- --localstatedir=/var/lib \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
--mandir=/usr/share/man \
--sbindir=/usr/sbin \
--sysconfdir=/etc \
+ $(DISABLE_LARGEFILE) \
$(DISABLE_NLS) \
);
touch $(PKG_BUILD_DIR)/.configured
@@ -63,13 +66,13 @@ $(PKG_IPK): $(PKG_BUILD_DIR)/src/chilli
mkdir -p $(PACKAGE_DIR)
$(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-$(IPKG_STATE_DIR)/info/openvpn.list: $(PKG_IPK)
+$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
$(IPKG) install $(PKG_IPK)
source: $(DL_DIR)/$(PKG_SOURCE)
prepare: $(PKG_BUILD_DIR)/.unpacked
compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/openvpn.list
+install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
clean:
rm -rf $(PKG_BUILD_DIR)