aboutsummaryrefslogtreecommitdiffstats
path: root/package/button-hotplug/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-10-17 22:45:58 +0000
committerJohn Crispin <blogic@openwrt.org>2012-10-17 22:45:58 +0000
commit16ed01db05cf25221a62baf3c8eba135f933a6b1 (patch)
tree405d52924fbc92967e8681bcca5e9c17d35aab8c /package/button-hotplug/Makefile
parent2372b1dbdb253065274b8a54846149d634bcea14 (diff)
downloadupstream-16ed01db05cf25221a62baf3c8eba135f933a6b1.tar.gz
upstream-16ed01db05cf25221a62baf3c8eba135f933a6b1.tar.bz2
upstream-16ed01db05cf25221a62baf3c8eba135f933a6b1.zip
[kernel] move lots of kernel related packages to the new system/ folder
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33830 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/button-hotplug/Makefile')
-rw-r--r--package/button-hotplug/Makefile53
1 files changed, 0 insertions, 53 deletions
diff --git a/package/button-hotplug/Makefile b/package/button-hotplug/Makefile
deleted file mode 100644
index 35ea6d411e..0000000000
--- a/package/button-hotplug/Makefile
+++ /dev/null
@@ -1,53 +0,0 @@
-#
-# Copyright (C) 2008-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=button-hotplug
-PKG_RELEASE:=3
-
-include $(INCLUDE_DIR)/package.mk
-
-define KernelPackage/button-hotplug
- SUBMENU:=Other modules
- TITLE:=Button Hotplug driver
- FILES:=$(PKG_BUILD_DIR)/button-hotplug.ko
- AUTOLOAD:=$(call AutoLoad,30,button-hotplug)
- KCONFIG:=
-endef
-
-define KernelPackage/button-hotplug/description
- Kernel module to generate button hotplug events
-endef
-
-EXTRA_KCONFIG:= \
- CONFIG_BUTTON_HOTPLUG=m
-
-EXTRA_CFLAGS:= \
- $(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=m,%,$(filter %=m,$(EXTRA_KCONFIG)))) \
- $(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=y,%,$(filter %=y,$(EXTRA_KCONFIG)))) \
-
-MAKE_OPTS:= \
- ARCH="$(LINUX_KARCH)" \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- SUBDIRS="$(PKG_BUILD_DIR)" \
- EXTRA_CFLAGS="$(EXTRA_CFLAGS)" \
- $(EXTRA_KCONFIG)
-
-define Build/Prepare
- mkdir -p $(PKG_BUILD_DIR)
- $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
-define Build/Compile
- $(MAKE) -C "$(LINUX_DIR)" \
- $(MAKE_OPTS) \
- modules
-endef
-
-$(eval $(call KernelPackage,button-hotplug))