aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-10 19:25:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-10 19:25:48 +0000
commit215ccb66e6abdaed0a41582d6b8c40ffa340eea7 (patch)
treee8ecd7ecc708bda6515831abaffbcb8d9ee65d5f /package/busybox
parentb49cdabd4ae2c0239dc12eda5e1b7a21b9c2e5dc (diff)
downloadupstream-215ccb66e6abdaed0a41582d6b8c40ffa340eea7.tar.gz
upstream-215ccb66e6abdaed0a41582d6b8c40ffa340eea7.tar.bz2
upstream-215ccb66e6abdaed0a41582d6b8c40ffa340eea7.zip
gcc: add llvm-gcc and llvm from trunk (does not successfully compile a target yet, but gets close)
SVN-Revision: 18019
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index eb0f0987e7..75bb315cc6 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -59,6 +59,10 @@ define Build/Configure
oldconfig
endef
+ifdef CONFIG_GCC_VERSION_LLVM
+ TARGET_CFLAGS += -fnested-functions
+endif
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \