aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-02-13 02:52:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-02-13 02:52:34 +0000
commita17580be4f3b18a57cbc030351abdc673e3dbb77 (patch)
treeac51093a76e4a05cdca087dcddbedd1a0f4e9e58 /package/busybox
parentde4ec6ce64f6257b9d07fb5f31ce82b03221cc2d (diff)
downloadupstream-a17580be4f3b18a57cbc030351abdc673e3dbb77.tar.gz
upstream-a17580be4f3b18a57cbc030351abdc673e3dbb77.tar.bz2
upstream-a17580be4f3b18a57cbc030351abdc673e3dbb77.zip
busybox: fix compile with librpc if necessary (required by nfs mount support)
SVN-Revision: 25507
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index d30be0de75..f4095c73c9 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -17,6 +17,7 @@ PKG_SOURCE_URL:=http://www.busybox.net/downloads \
http://distfiles.gentoo.org/distfiles/
PKG_MD5SUM:=a2ce1a951571da8c6e0eaf75b1acef60
+PKG_BUILD_DEPENDS:=librpc
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
@@ -36,6 +37,7 @@ define Package/busybox
MAINTAINER:=Nicolas Thill <nico@openwrt.org>
TITLE:=Core utilities for embedded Linux
URL:=http://busybox.net/
+ DEPENDS:=+BUSYBOX_CONFIG_FEATURE_HAVE_RPC&&USE_UCLIBC:librpc
MENU:=1
endef
@@ -63,6 +65,13 @@ ifdef CONFIG_GCC_VERSION_LLVM
TARGET_CFLAGS += -fnested-functions
endif
+LDLIBS:=m crypt
+ifdef CONFIG_BUSYBOX_CONFIG_FEATURE_HAVE_RPC
+ TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+ export LDFLAGS=$(TARGET_LDFLAGS)
+ LDLIBS += rpc
+endif
+
define Build/Compile
$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
@@ -71,6 +80,7 @@ define Build/Compile
EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
ARCH="$(ARCH)" \
SKIP_STRIP=y \
+ LDLIBS="$(LDLIBS)" \
all
rm -rf $(PKG_INSTALL_DIR)
$(FIND) $(PKG_BUILD_DIR) -lname "*busybox" -exec rm \{\} \;
@@ -80,6 +90,7 @@ define Build/Compile
EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
ARCH="$(ARCH)" \
CONFIG_PREFIX="$(PKG_INSTALL_DIR)" \
+ LDLIBS="$(LDLIBS)" \
install
endef